can't add the Trimble R1 receiver

1716
3
09-20-2018 02:53 PM
BingqingLiang
New Contributor

After the Trimble R1 receiver is connected to my iPhone 8 (verified in Trimble's GNSS Status App), I want to specify in Collector to use this receiver to provide GPS locations. However, in Collector - Settings - Location -Providers, it only shows Integrated Receiver is being used. When I click the + sign, nothing shows up and I can't find the R1 receiver. I have tired it on iPhone 6, 8, and 10 as well as iPad Pro and also tried to wait for at least 30 mins for each test, the problem stays the same on all iPhones - no extra receiver can't be shown in Collector (see attached). However, when I tested it in Windows, it works fine. Please help me to fix this problem ASAP as 90% of my students need to use iPhone to run this App.  

0 Kudos
3 Replies
Kylie
by Esri Regular Contributor
Esri Regular Contributor

Have you verified that you are using firmware version 5.03 or later? GPS receiver support—Collector for ArcGIS | ArcGIS 

0 Kudos
BingqingLiang
New Contributor

Thanks for the suggestion. I just updated it to the latest firmware and now I can't place the R1 in Bluetooth paring mode as it only allows me to switch on or off the power. 

0 Kudos
GaleShea
New Contributor III

The firmware update removes the need for a manual "pairing mode".  It will be automatically in pairing mode when on.  No steps needed other than scanning for BT devices on your phone to see and connect to the Trimble R1.

However - a recent update to the GNSS Status app (for iOS) had a bug that is being worked on that affected Collector.  The app is suspended in the app store until the iOS fix is posted by Trimble.

0 Kudos