Attributes fields not appearing for population during collection

182
4
Jump to solution
3 weeks ago
AlfredBaldenweck
New Contributor III

I have a series of layers with about 10 fields that need to be populated during collection. All of the layers reside in the same weblayer.

AlfredBaldenweck_1-1622737399156.png

However, when trying to collect, a maximum of two fields appear. Some layers don't have any fields appear.

AlfredBaldenweck_2-1622737571663.png

 

The only other time I have had something like this happen was when I added fields to layers I had already published to AGOL; I have not touched these since I first uploaded them. None of the fields are set to be read-only. 

What is causing this, and how do I fix it?

Thanks!

 

0 Kudos
1 Solution

Accepted Solutions
JasonCyphers
Occasional Contributor

In your map, if you go to the pop-up configuration for that feature, and select "Configure Attributes" is Edit checked next to the attributes you need to edit?

 

JasonCyphers_0-1622738188752.png

 

View solution in original post

0 Kudos
4 Replies
JasonCyphers
Occasional Contributor

In your map, if you go to the pop-up configuration for that feature, and select "Configure Attributes" is Edit checked next to the attributes you need to edit?

 

JasonCyphers_0-1622738188752.png

 

View solution in original post

0 Kudos
AlfredBaldenweck
New Contributor III

I'm sorry, I don't even know where you went to get that window. I have nothing that says "Configure Attributes" in my pop-up configuration pane. I've checked in Map Viewer and in Map Viewer Classic to make sure I'm not missing it.

Configure fields in Map Viewer just prompts me to change the alias and that's it.

Checking in the layer's item details, all the fields are set to be editable.

0 Kudos
JasonCyphers
Occasional Contributor
  1. In AGOL or your Enterprise Portal, click on the map you are utilizing in your app.
  2. Click on Open in Map Viewer
  3. Under the content menu (on the left), hover over the feature then click on the three dots to open the "More Options" menu
  4. Click on Configure Pop-Up
  5. Click on the blue, Configure Attributes text.  That will get you to the screenshot I sent above.

If any of the above is unclear, DM me and perhaps I can talk you through it.

0 Kudos
AlfredBaldenweck
New Contributor III

Okay, that solved it for  maps created in Map Viewer Classic. How can I do this in Map Viewer (formerly Beta)?

Thanks

0 Kudos