ArcGIS Collector won't show location or accuracy after 10.4.0 update

12778
33
08-01-2016 04:38 PM
MatthewTwietmeyer
New Contributor III


I updated ArcGIS Collector to 10.4.0 and now that brings with it new configuration for using a receiver. My problem now is that Collector can't fix in on my location nor give me a accuracy in ft with my Garmin GLO device. When I go to turn on my location within the map the device can't find my location. I suspect it has to do with the location profile settings, but I can't seem to figure that out. My offline map is in WGS_1984_Web_Mercator _Auxillary_Sphere. The default system is GCS WGS 1984, is there a necessary profile for the garmin glo to function?

Anyone else having this issue?

Matthew Twietmeyer

33 Replies
BobDay
by
New Contributor II

Hi All, 

 

I too had problems getting our location accuracy (bottom left corner of Collector screen) and the blue dot (user’s location) to show up after I selected the Trimble Unit (R1) as the Collector App's "Provider" in Location Settings. I am glad that the GNSS overwrites the GPS no matter what the application displays, however I want my users to be able to know their accuracy while they collect data.

 

By adding some GNSS Metadata Fields to my feature service in AGO, I was able to get the blue location dot to show up, as well as see my GNSS accuracy.

 

Step 1: Add some (not all are needed) GNSS Accuracy Metadata Fields to points feature class in AGO, save web map

Step 2: Open iPad settings, connect Bluetooth to GNSS receiver

Step 3: Open GNSS Status App (iPad, Android) and connect to GNSS receiver

Step 4: Open Collector and change “Provider” settings to your GNSS receiver instead of the Integrated Receiver, this will make Collector ask if it can open the GNSS Status App, allow it to do so

Step 5: Open Collector Web Map, it should zoom to where ever you are and you should see your location dot as well as the GNSS receiver accuracy

 

My experience is that feature services without the GNSS accuracy fields do not allow the GNSS receiver to be the “Provider” in the locations settings. Follow my link above and add the GNSS accuracy fields to your feature service (you can do this in AGO so you don’t have to re-publish the service), then try making your GNSS receiver the “Provider” in Collector without any issues.

 

I hope this works for you!

~Casey

JayRiester1
New Contributor III

Casey,

Thank you for this detailed information.  Hopefully this helps the users that were experiencing issues of current accuracy indicator in Collector for iOS.

I already had GNSS Metadata field from the beginning so maybe this is why I never experienced this issue?

Can someone from the Esri Collector team confirm that you have to have a certain Metadata field in order for the Accuracy location to show up in the Full release of Collector for iOS?

Thanks,

Jay

0 Kudos
MarkYerington
Occasional Contributor III

Wow lots of activity, I will try adding metadata fields to the dataset and see what happens.  Thanks!

0 Kudos
by Anonymous User
Not applicable

One more thing I forgot to add in my previous post (posted under Bob Day's profile by accident)...

Step 1.5: Create Tracking Feature Layer in AGO and add it to your web map.

Sorry for that oversight, hope this works.

Thanks, 
Casey

0 Kudos
CliffHoeffner1
New Contributor II

I can't comment to the Garmin GLO, but I can to the Trimble R1.

To get the positional accuracy into Collector with the Trimble R1 you need to do the following.

  1. Install the Trimble GNSS Status App on your Device and set the following
    1. (Menu -> Real-Time Config) Set your real-time correction source (Usually SBAS)
    2. (Menu -> NEMA Settings) Tap the chevron arrow at the bottom left to move all the NMEA messages to the right.  Tap Apply to Receiver at the bottom.  Tap SSP 1.  Tap Save.
  2. In Collector, Tap Location Provider.  Tap the "+" to add a new receiver.  You should see the R1 listed as "GNSS & the last 5 digits of the SN#, ex GNSS: 12345. Tap it and set the Height (not required). Tap Ok to save.  You should now see the R1 as a provider.  Tap it.  You will see the GNSS Status Utility open then disappear.  After this you should see a "check" Next the the R1.  Tap the back button to return to the settings screen

From Testing with the Beta iOS, Andriod, Windows 10, iOS nonbeta (pre iOS 10 upgrade) & Windows 10 non-beta, adding and setting up the GPS Meta data fields are not required to see the accuracy of the R1 in the map window accuracy badge.

If your having issues,

  1. I would check that your GNSS Status app is updated to the the latest version and that your R1 firmware up to date.
  2. Delete any connections you created before and redo #1 & #2 above.
GaleShea
New Contributor III

Bottom line is - when the settings are correct - the Accuracy reading in Trimble GNSS Status and in Collector should both read the same distance value.  And when you have corrections being applied - under open sky, you should expect reliable sub-meter results with an R1.

    Remember also - regarding your Location Profile for the continental US - if using SBAS with the ESRI Web Mercator basemaps - the Default can be used. (No transformation needed.)  But if you are using a RTN/VRS correction network that provides NAD83 (2011) based corrections - your Location Profile will need to set-up the correct datum transformation.  (Here in Wisconsin I named my Profile "Wiscors").

Collector Location Profile for NAD83 (2011) to WGS84 transformation 

Other locations will be similar - or else you may introduce the infamous ~1 meter datum shift problem.

JayRiester1
New Contributor III

Here is a screen shot showing the SBAS/WAAS with Trimble R1 accuracy in the Trimble GNSS Status App and in Collector.  I had left Collector in metric.  It says 42 CM.

Jay

Trimble GNSS Status "Trimble R1" with ArcGIS Collector

MichaelHeyroth
New Contributor III

I have tried the method described by Cliff Hoeffner with a R1, collector and no metadata. 

I seems to be working great. The true accuracy is displayed in feet( about 1.5 ) in the collector app. 

thanks cliff

0 Kudos
GaleShea
New Contributor III

Another item that likely affects the ability to display your location is the map extent of the base map in the Collector project.   If you and your GPS device are outside the set map extent - it may have trouble with location display.

(Example today, a project in Iowa with a map extent of the Dubuque area - would not display GPS location when opened in Collector in the Iowa City area.)

JayRiester1
New Contributor III

Here is a blog post that I created about setting up the Location Profile in Collector. 

https://mapsupport.seilerinst.com/2017/07/21/location-profile-setup-for-real-time-corrections-with-e...

I am using my Trimble R2 Sub Foot receiver with Android phone as the example with Wisconsin DOT VRS - "WISCORS". 

I hope this helps.

Location Profile setup in Esri Collector for High Accuracy Real-time

Thanks,

Jay