ArcGIS Collector not honoring Hosted Feature Layer Views

48
0
3 weeks ago
Highlighted
New Contributor II

I have a set of hosted layers for data collection that are built to satisfy three types of inspections. Each inspection type has specific requirements, but also requires so many similar features that I identified it was more efficient to create a master dataset for each type (points, lines, and polygons), and create view layers that showed the data specific to each inspection type. One inspection type requires that a certain point feature be its own entity, but rather than create a hosted feature layer because this same feature is also required in other inspections, I wanted to keep it in the same master layer so that it shows when multiple inspections are preformed at one site and only data that was not captured in previous inspections unique to the overlapping one is required.

The point feature in question is symbolized based off a text domain (list in AGOL terms), and the view layers have all unnecessary features removed from visibility in the symbology, and when viewed in the webmap, the view of the hosted view layer is honored. However, when I open the same map in Collector, I'll see all the domain types with a blank symbol, or a randomly picked symbol from the master layer's symbology despite it only supposed to be showing one type.

In this case, I'm trying to filter out about 20 different types of features and only display a feature representing oil tanks, then have another view layer show the rest of the points that are required for the inspection. I've tried applying filters as well to the hosted view layer with no luck. I'm using the latest ArcGIS Collector (not Collector Classic), and I'm having the same issue on both the Android and iOS devices.

I've had to instruct field workers to use the search function when adding features for this specific map because it requires to most filtering, but I'd rather them be able to just see the layers as I see them in the web map without seeing all the feature types not required for the current inspection.

Reply
0 Kudos
0 Replies