"Enable Sync" is greyed out and no longer working

2743
3
04-24-2014 05:11 AM
NicholasLaMar
New Contributor II
Hi,

We are in the process of testing Collector for offline use. For the last few weeks I've been able to upload files to AGO, create a feature service and enable sync so we can edit in the offline mode. Yesterday I noticed however that this process is no longer working. I went back and checked our previous maps and features and the enable sync button is now greyed out. What's changed???

We are still running 10.1, and I'm posting my features directly to AGO (we are not using our Server). I've seen some postings where it says that you need 10.2.2 to enable offline editing, but if we are posting directly to ESRI's Servers through AGO do we need 10.2.2 on our end? This was working fine last week with our current configuration.

Any insight would be much appreciated.

Thanks!

Ryan
Tags (2)
0 Kudos
3 Replies
RussellRoberts1
Esri Frequent Contributor
Once sync is enabled on a hosted feature service it cannot be disabled. So if you are seeing it greyed out it is already enabled. Are you seeing an issue in AGOL or in Collector?

Thanks
Russ
0 Kudos
NicholasLaMar
New Contributor II
Hi Russ,

The issue originates in AGOL and results in an issue in Collector since we are not able to download the map for offline editing. For features that we've previously enabled sync on what you've described makes sense. The problem now however is that we're trying to load new features to AGOL and create hosted feature services and then enable sync on those. Sorry if my note before wasnt clear on that.

I just did another test tonight and I can get everything working, but I had to create a new map and then load the data into that map. Perhaps the original map got corrupted somehow? Is that even possible? I still can't enable sync from the original map. We should be able to move forward with the new map.

Thanks for your response.

Ryan
0 Kudos
DuncanHornby
MVP Frequent Contributor

Just want to say I had exactly the same problem and was pulling my hair out. I read this thread and created a new map in AGOL then added my "synced" feature layers and it just worked... Thanks!

0 Kudos