Save snapshot only exports lower left part of viewport

1489
5
10-10-2014 12:18 AM
BrunoSeiler
New Contributor

When I use save snaphot it only exports the lower left part of the viewport (see attached pics).  I am working on a Mac with OSX 10.9.5 with Retina display and the issue appears with both CityEngine versions 2013.1 and 2014.1. However I didn't have this issue with my older Mac with a slightly older OSX and without Retina display. Any idea why this happens and how I could solve it?

Tags (2)
0 Kudos
5 Replies
MatthiasBuehler
Regular Contributor

Hi Bruno,

I heard from Roman you're talking about screenshots in python.. or is it the same via the UI ?

Just to make sure ..

Matthias Buehler

Head of 3D Technologies

twitter: @MattB3D

----------------------------------

Garsdale Design Limited
matthias.buehler@garsdaledesign.co.uk

www.garsdaledesign.co.uk

0 Kudos
BrunoSeiler
New Contributor

Hi Matt

Small World :-). We have exactly the same issue in the UI and in python...

0 Kudos
MatthiasBuehler
Regular Contributor

I tried here and it seems to work fine .. both via UI and python ..

strange.. does this happen in each and every snapshot you take ?

m.

Matthias Buehler

Head of 3D Technologies

twitter: @MattB3D

----------------------------------

Garsdale Design Limited
matthias.buehler@garsdaledesign.co.uk

www.garsdaledesign.co.uk

0 Kudos
BrunoSeiler
New Contributor

Hmm.. Yes, it happens with every snapshot. It's definitely related to the mac retina display. I found a workaround on the apple website in the meantime. You need to open cityengine in low-resolution mode when you want to export snapshots and then it works fine:

  • Quit the application if it is currently open.
  • In the Finder, choose Applications from the Go menu.
  • In the Applications folder that opens, click the application's icon so it is highlighted.
  • Choose Get Info from the File menu.
  • Place a checkmark next to "Open in Low Resolution" to enable Low Resolution mode.
  • Close the window and double click the Application to reopen it.Note: You may also contact the developer of the application to determine if they are offering an update to the application for the Retina display.

So I guess this means that you can't work in the high-resolution mode when you want to export snapshots. Fortunately the rest of the functionalities in CityEngine seem to work fine in both modes.

Thanks for your help!

0 Kudos
MatthiasBuehler
Regular Contributor

ah, Retina, ok.

I'll make sure the devs see this.

good you have a workaround for now.

cheers !

Matthias Buehler

Head of 3D Technologies

twitter: @MattB3D

----------------------------------

Garsdale Design Limited
matthias.buehler@garsdaledesign.co.uk

www.garsdaledesign.co.uk

0 Kudos