"Prefetching Data".. any way to see what is being prefetched?

2006
2
03-21-2016 08:59 AM
LR
by
Regular Contributor

I have a rather large project with hundreds of different quite lengthy rule files (loads of switches and cases leading to different modelling and/or textures) that generate complex facades. In addition to that the scene contains hundreds of trees (one rule, analytical) and a semi-complex street network (rule: street constuction). On top of that, the project was made across different CE versions by a bunch of people.

When I import the project and try to open the scene, CE hangs at "Prefetching Data" for up to ten minutes before the generating starts, or gets stuck. Obviously this isn't very great. What's the culprit? The shape/object number, the facade complexity, the rule complexity, the project originating in an old version, or all of these? Can I somehow see what exactly is being prefetched?

Tags (2)
0 Kudos
2 Replies
ThomasFuchs
Esri Regular Contributor

Hello Z R

In the "Prefetching Data" step the scenefile gets loaded. Normally this is quite fast and model generation takes most of the time. But as you are mentioning, your scene is made with an older version of CE. Therefore conversion of legacy data might be needed at startup. Once the scene is loaded, you could save it in the new format and try if opening is now faster.

If there is no change, another way of narrowing down the problem is, to remove layers and save/re-load the scene until the prefetching step is faster.

LR
by
Regular Contributor

I figured that much

Tossing away all the building rules and street network layer sped the prefetching up by a few minutes (removing the terrain did almost nothing) but I obviously can't remove these. Adding a good chunk of the rules back also didn't make the prefetching time shoot up as much as expected. Prefetching is also faster on subsequent openings of a scene after the initial import (regardless of the version the project was exported from), so I guess something (cgbs?) gets cached somewhere?

I guess there's no log written detailing the prefetching process?

0 Kudos