how to fix georeference of imported .dae models or KML in/for CityEngine scene?

1956
3
11-18-2016 04:58 AM
LessieOC
New Contributor III

Hello,

When I import .dae models into a georeferenced cityengine scene they are placed at the origin. When importing kml models, they are offset.  My scene is Geo-referenced already. How do I fix either, preferably the .dae imports?  

I tried converting a (static) model to shapes but then it dissapears entirely.  I have the same models in kml but they seem to come in with an offset, so also in the wrong place. I am using CityEngine 2015.2.

Also, how so you check the coordinate values of the model?

 Sorry, not too experience with all of the above. Thanks for any help in advance..

L.

0 Kudos
3 Replies
ThomasFuchs
Esri Regular Contributor

Hello Lessie,

For georeferencing DAE Collada files, KML is the way to go. The geo reference is added by the KML <Location> tag.

It specifies the exact coordinates of the Model's origin in latitude, longitude, and altitude. Latitude and longitude measurements are standard lat-lon projection with WGS84 datum. Altitude is distance above the earth's surface, in meters, and is interpreted according to <altitudeMode> or <gx:altitudeMode>.

For further information please consult the KML documentation: Models  |  Keyhole Markup Language  |  Google Developers 

On import to CityEngine the KML lat-lon WGS84 coordinates are projected to the scene's coordinate system.
To narrow it further down, could you please answer the following questions?

  • Which scene coordinate system are you using?
  • How large is the offset? Is it constant?
  • Are the KMLs located correctly in ArcGIS Earth ?
LessieOC
New Contributor III

Hi Thomas,

Thanks for taking the time to help me. The kml models are of underground objects and when I tried looking at them with Google E. they are not visible, but when placing the push pins they seem to be on the right area.  I am not using WGS1984 in my cityE. model so that explains their shift. The shift is consistent. How how do I change their projection within the cityengine? My scene is in epsg: 28992. I can't easily find a 'reproject' option. Alternatively, how do I assign a CRS to the .dae models? There are about 50 objects. Or, what else do you think I can I try.

Thanks,

L.

0 Kudos
ThomasFuchs
Esri Regular Contributor

Hi Lessie,

Thanks for the additional info. There have been some changes to the height conversion that do affect EPSG Projection 28992 - Amersfoort / RD New.

  • If possible, please use the latest version of CityEngine CityEngine 2016.1 release notes—Esri CityEngine | ArcGIS for Desktop .
  • Otherwise you could make a new scene using the corresponding UTM coordinate system (EPSG:32634).
  • 3rd option is to export the KML from CityEngine, adding an Global Offset for Y to compensate for the shift (Altitude Mode = absolute).