Align shapes (river) to terrain

2203
5
07-29-2015 01:37 PM
ScottAulen2
New Contributor III

What's the best way to align shapes (in this case water features) to a terrain and still be able to apply textures?  If I use the the Project All option I can get the shapes to align properly but whenever I then go to apply a texture I get the flickering facades.

0 Kudos
5 Replies
NathanStocker
New Contributor III

Could you just set an offset when aligning the shapes to the terrain? That way they'd sit just over the land and not overlap (causing the flickering).

Alternatively, you could apply a basic rule that extruded the shape and apply the texture to the resulting model - that would sit over the land as well.

Either way, it would just be a very small offset/extrusion, so it would still look like it was on the ground.

0 Kudos
ScottAulen2
New Contributor III

Nathan

The issue isn't with overlap on the terrain imagery (in fact I've turned it off) it has to do with the imported shape itself.  The first attached picture shows the shape after it has been aligned to the terrain (Project All option).  Everything seems fine but when I try to apply a color or texture I get picture two as a result.

I have also tried to extrude the shape slightly, apply a texture and then align to terrain but the results are odd, I think because of the varied terrain. 

Would converting the data in Arcmap to Multipatch Polygons help?  I could set the z value to something very smallPicture 1.PNG

Picture 2.PNG

0 Kudos
ScottAulen2
New Contributor III

This post seems to address a similar problem but it's from 2013. 

Matthias Buehler​ would you still recommend the same solution or have the terrain tools been updated so as to handle this differently?

0 Kudos
NathanStocker
New Contributor III

Oh I see - it's always frustrating that aligning shapes only does the vertices! It causes me the same headaches.

Short of cutting the shapes up small, or extruding them up enough that they are totally above the terrain (which looks funny), I don't think there's much you can do. Matthias would certainly know more though!

In the picture, it looks like shapes are turned on and are overlapping with the models. I presume it doesn't help just turning shapes off?

0 Kudos
ScottAulen2
New Contributor III

You're right, I did have both shapes and models turned on and turning off the shapes solved the conflict.  However, I was still experiencing a few other invalid geometry issues so I converted the feature class data into multipatch in ArcMap and then brought them into CityEngine which seems to work better. 

I'd be curious to know which workflow the CityEngine developers would recommend.  Is there much of a performance difference either way?

0 Kudos