Why can't I set Territory balance variables with ArcGIS Pro BA?

338
5
Jump to solution
04-22-2020 02:15 PM
JerryGarcia
Occasional Contributor II

When trying to set balance variables, I get the following message:

"selected territory level does not have variables suitable for balance or constrain territories"

I added level variables from my base layer that I enriched with home household size, value, income, etc... 

Shouldn't I be able to set these variables in "set balance variables" and "solve" again to create new a new Territory layer balanced with these variables?

Thanks!

1 Solution

Accepted Solutions
DanielLee2
New Contributor III

Hi Jerry, what did you set for the statistics when adding the variable? If you want to use it in balance, it needs to be "Sum" 

View solution in original post

5 Replies
DanielLee2
New Contributor III

Hi Jerry,

You need to first use the Add Level Variables tool. That will add the variables to the level (e.g. territories). Then you can run the Set Balance Variables tool or the Set Territory Attribute Constraints tool. The final step is the run the Solve tool.

JerryGarcia
Occasional Contributor II

Thanks for replying.  Yes, I believe I am following your recommended steps, but have an issue with Set Balance Variables?  Any ideas?  See attached pics.  Thank you!

JerryGarcia
Occasional Contributor II

Hello Daniel:  Please let me know if you have any ideas or need more information.  Thank you!  

DanielLee2
New Contributor III

Hi Jerry, what did you set for the statistics when adding the variable? If you want to use it in balance, it needs to be "Sum" 

View solution in original post

JerryGarcia
Occasional Contributor II

Thank you!  I was able to balance territories once I added level variables with statistics set to "sum".

Best!