Error upliading ipa to app store

216
3
Jump to solution
04-07-2020 04:27 AM
JorgeFrade_Martínez
New Contributor III

Reply
0 Kudos
1 Solution

Accepted Solutions
ErwinSoekianto
Esri Regular Contributor

Jorge, 

With AppStudio 4.2, iPad Multitasking is enabled by default. With that being said, if iPad Multitasking is enabled, all four orientations need to be supported in the app. 

Based on the screenshot you provided, it looks like your app has landscape options disabled. Please enable all four orientations if you want to enable iPad Multitasking. 

But if you don't want or intend to have iPad Multitasking enabled, you can set display.ios.windowsMode to "fullscreen" in appinfo.json

"display": {
"ios": {
"windowMode": "fullscreen"
}
}

Thank you,

Erwin

View solution in original post

Reply
0 Kudos
3 Replies
ErwinSoekianto
Esri Regular Contributor

Jorge, 

With AppStudio 4.2, iPad Multitasking is enabled by default. With that being said, if iPad Multitasking is enabled, all four orientations need to be supported in the app. 

Based on the screenshot you provided, it looks like your app has landscape options disabled. Please enable all four orientations if you want to enable iPad Multitasking. 

But if you don't want or intend to have iPad Multitasking enabled, you can set display.ios.windowsMode to "fullscreen" in appinfo.json

"display": {
"ios": {
"windowMode": "fullscreen"
}
}

Thank you,

Erwin

View solution in original post

Reply
0 Kudos
JorgeFrade_Martínez
New Contributor III

I want to use only the portrait mode. I added the fullScreen key to the appinfo.json but i still have the same problem...

Reply
0 Kudos
ErwinSoekianto
Esri Regular Contributor

 My apologies, the correct appinfo.json value to disable iPad Multitasking is below (they case sensitive), I will update the original post.

"display": {
"ios": {
"windowMode": "fullscreen"
}
}


Reply
0 Kudos