Error sending apk to google play

111
2
Jump to solution
01-27-2020 03:11 AM
JorgeFrade_Martínez
New Contributor III

Reply
0 Kudos
1 Solution

Accepted Solutions
ErwinSoekianto
Esri Regular Contributor

Jorge, 

What AppStudio Desktop version did you use to make this build? Did you use Cloud Make to build the APK? Did you sign your APK with a store certificate when you build this using Cloud Make? '

The unsigned android build is referred to as debug APKs, when a certificate is not supplied, the APK gets automatically signed using a developer debug certificate available on the build machine, Google Play Store refers this APK as a debuggable APK. So you need to go to Settings > Platforms > Android > Sign Package. Sign your app—AppStudio for ArcGIS | Documentation 

Regarding the target API level, you can change this in the appinfo.json, the property is called deployment > android > targetSdkVersions. It looks like you have changed or set this value, you can either change it or if you just remove that property so that the Cloud Make service can take care of that automatically. Edit appinfo—AppStudio for ArcGIS | Documentation 

Thank you,

Erwin

View solution in original post

2 Replies
RobertBorchert
Frequent Contributor II

You need to disable debugging on your app first

Reply
0 Kudos
ErwinSoekianto
Esri Regular Contributor

Jorge, 

What AppStudio Desktop version did you use to make this build? Did you use Cloud Make to build the APK? Did you sign your APK with a store certificate when you build this using Cloud Make? '

The unsigned android build is referred to as debug APKs, when a certificate is not supplied, the APK gets automatically signed using a developer debug certificate available on the build machine, Google Play Store refers this APK as a debuggable APK. So you need to go to Settings > Platforms > Android > Sign Package. Sign your app—AppStudio for ArcGIS | Documentation 

Regarding the target API level, you can change this in the appinfo.json, the property is called deployment > android > targetSdkVersions. It looks like you have changed or set this value, you can either change it or if you just remove that property so that the Cloud Make service can take care of that automatically. Edit appinfo—AppStudio for ArcGIS | Documentation 

Thank you,

Erwin

View solution in original post