Error during cloud make for Android

870
11
Jump to solution
07-06-2021 10:06 AM
RaufShaikh
New Contributor III

Hello Friends,

I am building an App in AppStudio. I have generated the keystore file using the command: keytool -genkey -v -keystore [keystore_name].keystore -alias [alias_name] -keyalg RSA -keysize 2048 -validity 10000 as mentioned here https://doc.arcgis.com/en/appstudio/extend-apps/signyourapp.htm under section Sign your Android app .

Surprisingly, when I run the command it doesn't ask me to perform step 7, Enter a key password. This password can be unique, or press Enter to use the same password as the keystore password. Without asking me to enter Key password the Keystore file gets genearted with .keystore extension. I have linked this keystore file with my App by going to settings>platforms>Android , KeyStore file path.

Now, when I do cloud make we have to enter KeyStore and upload key passwords, here I enter the same password for both KeyStore and Upload key, which I have entered for my KeyStore file while generating it using the keytool. When I start the make processs, it gives me the below error

 

RaufShaikh_0-1625590970825.png

 

Any help on this is much appreciated.

 

Thanks,

Rauf

0 Kudos
1 Solution

Accepted Solutions
RaufShaikh
New Contributor III

Hi Carlos/ Erwin,

Try adding flag -storetype jks to the keytool command  as below:

keytool -genkey -v -keystore {Name].keystore -alias [Alias] -storetype jks -keyalg RSA -keysize 2048 -validity 10000

Apparently in order to perform cloud/local make for android platform using AppStudio, the keystore file should have .jks extension or if you are following the AppStudio documentation  https://doc.arcgis.com/en/appstudio/extend-apps/signyourapp.htm then add flag -storetype jks to the keytool command mentioned in that article.

Once I generated Keystore file using the above mentioned keytool command, I was able to successfully perform the cloud make.

Esri team should update the link  https://doc.arcgis.com/en/appstudio/extend-apps/signyourapp.htm to include this information.

I hope this will help.

Thanks,

Rauf

View solution in original post

11 Replies
ErwinSoekianto
Esri Regular Contributor

Rauf,

 

It looks like there is an issue with the password, can you try changing the password to not use special characters?

 

Erwin.  

0 Kudos
Carlos_Carvalho
New Contributor II

Hi Erwin,

I'm having the same issue. I changed the password for letters only but i get the same error.

Can you help?

Thanks.

0 Kudos
RaufShaikh
New Contributor III

Hi Carlos/ Erwin,

Try adding flag -storetype jks to the keytool command  as below:

keytool -genkey -v -keystore {Name].keystore -alias [Alias] -storetype jks -keyalg RSA -keysize 2048 -validity 10000

Apparently in order to perform cloud/local make for android platform using AppStudio, the keystore file should have .jks extension or if you are following the AppStudio documentation  https://doc.arcgis.com/en/appstudio/extend-apps/signyourapp.htm then add flag -storetype jks to the keytool command mentioned in that article.

Once I generated Keystore file using the above mentioned keytool command, I was able to successfully perform the cloud make.

Esri team should update the link  https://doc.arcgis.com/en/appstudio/extend-apps/signyourapp.htm to include this information.

I hope this will help.

Thanks,

Rauf

View solution in original post

RaufShaikh
New Contributor III

Generating keystore using the below command should also work.

keytool -genkeypair -alias upload -keyalg RSA -keysize 2048 -validity 9125 -keystore keystore.jks

Carlos_Carvalho
New Contributor II
0 Kudos
Carlos_Carvalho
New Contributor II

Thanks RaufShaikh, it worked.

Thanks for your advise, I appreciate it.

kind regards

0 Kudos
RaufShaikh
New Contributor III

Hi Carlos,

I am glad it helped. Could you please mark it as accepted solution?

Thanks,

Rauf

Carlos_Carvalho
New Contributor II

No problem, how can I do it?

0 Kudos
RaufShaikh
New Contributor III

By clicking on the Accept as Solution button below my reply where I have provided the solution.

Thanks,

Rauf