Selection propagation doesn't work in Schematics Configurable WebApp SIlverlight

3052
1
Jump to solution
07-31-2015 07:45 AM
FlavieMORAUX1
Occasional Contributor

Hy,

I'm using the ESRI Schematics Configurable WebApp Silverlight (Source Code) and I have a problem with the propagation of selection.

In the direction of geography to schema , selection propagation does not work (whatever silverlight version 4/5). While the other way it works.

Here the webapp source ==> http://www.arcgis.com/home/item.html?id=49c44667103f4d4082db91ee4e416eb7

When the related schematics features are recovered i have the following exception :

Methode not found : 'Void ESRI.ArcGIS.Client.Tasks.QueryTask.ExecuteAsync(ESRI.ArcGIS.Client.Tasks.Query)'.

Here is the stack trace :

at ESRI.ArcGIS.Client.Schematics.SchematicDiagram.Select(IEnumerable`1 objectLists, Boolean clearSelection)

at SchematicsWebComplete.MainVM.QueryAssociatedSchematicFeaturesCompleted(Object sender, SchematicAssociatedFeaturesEventArgs e)

I don't see the relation between Select method and QueryTask... Any ideas?

Thanks.

Flavie

PS : For information i use the same data as in the ESRI online sample

http://serverapps101.esri.com/SchematicsWebApplications/SchematicsConfigurableWebApp/

0 Kudos
1 Solution

Accepted Solutions
FlavieMORAUX1
Occasional Contributor

The problem is related to the fact that I use the API SILVERLIGHT 3.2. With version 3.1 it works well.

Problem solved.

View solution in original post

0 Kudos
1 Reply
FlavieMORAUX1
Occasional Contributor

The problem is related to the fact that I use the API SILVERLIGHT 3.2. With version 3.1 it works well.

Problem solved.

View solution in original post

0 Kudos