Buffering a point

378
4
11-20-2013 05:33 AM
JasonCleaver
Occasional Contributor
When using the geometry service to create 100ft buffer around a point, the returned buffer is about 70ft.  I think it has to do with the spatial references, however I am not sure.   The inSR and outSr are both 102100. Do I need to set the bufferSR to something different as in the example below?


Example 1: In this example, the point [-117, 34] is buffered in WGS 84  (4326) at a distance of 1000 meters. The geometry should be buffered using the  Web Mercator projection (102113) and the output polygon should be returned in  WGS 84 (4326).

Thanks,

Jason
Reply
0 Kudos
4 Replies
RobertBorchert
Frequent Contributor II
The system is buffering is based on the units in the projection.

search for   buffer analysis and use that tool instead.  There you can specify the units you want and will buffer in those units.

Or if you can figure out the conversion simply do that.  One of my clients systems is in Meters and I need to do a 500 foot buffer around underground power lines every now and then.  I simply select the lines and put in 152.40 which is in meters.
Reply
0 Kudos
JasonCleaver
Occasional Contributor
In code, I am setting the distances and unit, so to me the buffer service should honor them.
Reply
0 Kudos
BobNichols
New Contributor III
What method are you using to calculate your buffer distance, Geodesic or Planar?  I have found that in my neck of the woods, Washington State, that the planar projection when used for calculating distances is very inaccurate.  I always have to use Geodesic in my apps.

ESRI has an example of adding a buffer to a point found here,http://resources.arcgis.com/en/help/silverlight-api/samples/start.htm#BufferPoint, but I am sure that you have already seen that.

Hope that helps!
Reply
0 Kudos
JasonCleaver
Occasional Contributor
Thanks...I guess my misunderstanding of coordinate systems is the issue.  It looks like when using ESRI's basemaps which are in 102100, I have to set the bufferSR to 4326 and set geodesic to true.

Jason
Reply
0 Kudos