ArcGIS API for Silverlight V3.0 is now live

375
3
06-20-2012 10:44 PM
DominiqueBroux
Esri Frequent Contributor
ArcGIS API for Silverlight V3.0 is now live, the main links are:
Enjoy!
0 Kudos
3 Replies
JoeHershman
MVP Regular Contributor
Dominique,

I am having some problem with the SDK.  On all the pages for the Actions I get an error such as this:

A value of type 'ToggleLayerAction' cannot be added to a collection or dictionary of type 'TriggerActionCollection'.

When I try to open one of those pages when the application is running it crashes on the line for downloading the xaml page

It seems like something related to the Blend library, but not really sure.

Any thoughts?

Thanks
-Joe
0 Kudos
DominiqueBroux
Esri Frequent Contributor
Hi Joe,

Not sure if it's your case, but that might happen when changing the target SL version of a project when some cached dlls are still used.

Double check the version and the location of your referenced dll's.
If your target SL5, the ESRI dlls should be the version 3.0.0.388 coming from the Silverlight5/3.0 directory and the system dlls should be version 5.0.5.0.

Then :
  - clean your solution
  - remove obj and bin directories
  - exit visual studio
  - try again

Hopefully this will work :confused:
0 Kudos
JoeHershman
MVP Regular Contributor
Seems I was using the Silverlight 4 version of the Blend System.Windows.Interactions assembly.  Doh :eek:
0 Kudos