can't seem to connect to ArcGIS using python API

703
3
Jump to solution
03-07-2020 10:54 AM
ShaiSussman
New Contributor II

I'm working with google colab, and arcgis python api, Last week I was able to login using the GIS module.

but today after I ran the login operation and I get this message:

error message after trying to login

it seems like the their is a problem with the name (maybe the period?) but with other logins I don't have a problem.

what could be the problem and how can this be resolved?

so it seems as if something has changed with the arcgis python api, because last week I was able to run login.

secondly is it possible to ask from my administrator to rename the user if It's only a matter of the name?

thanks in advance?

Thanks in advance,

Shai

0 Kudos
1 Solution

Accepted Solutions
HenryLindemann
Esri Contributor

Hi @ShaiSussman, try to update the API version if you are not using the latest's version I know there was a issue with points in the username at some point. I tested it in ArcGis API for python 1.8.4 and a username with a . in it is working.

Regards

Henry

 

View solution in original post

3 Replies
MingHan
New Contributor III

Hi How you add arcpy into colab? Thanks.

Ming

0 Kudos
mody_buchbinder
New Contributor III

Hi Shay

Can you login from simple web page without python API? Maybe the problem is with your account and not with Python API

Have fun

Mody

0 Kudos
HenryLindemann
Esri Contributor

Hi @ShaiSussman, try to update the API version if you are not using the latest's version I know there was a issue with points in the username at some point. I tested it in ArcGis API for python 1.8.4 and a username with a . in it is working.

Regards

Henry

 

View solution in original post