Proper setup of LERC layer?

227
5
Jump to solution
05-19-2021 07:05 AM
LizEidsness
New Contributor III

I am exploring the use of lerc and client side handling of pixel data.  In the specs I see it as capable, however I'm not sure how to configure my layers to get it to work.  One is a classified one like landcover (just doesn't show), the other based on floating point values (gives an infinity error).

Is this a bug, our service, or user error on configuring the layer?  ArcGIS server 10.41 (should be supported as of 10.3)

codepen: https://codepen.io/lizeidsness/pen/gOmLovj

LizEidsness_1-1621431534564.png

 

 

 

 

 

 

0 Kudos
1 Solution

Accepted Solutions
UndralBatsukh
Esri Regular Contributor

Hi there, 

Yes, the issue exists because of the combination of the version of your arcgis server and lerc decoder used for the older services in the JS API. With that, we fixed this issue at JavaScript API version 4.20. This version will be released late June 2021. 

Hope this helps,

-Undral

View solution in original post

5 Replies
UndralBatsukh
Esri Regular Contributor

Hi there, 

I can reproduce the issue you described with this service only. The other two services are loading and displaying as expected. In any case, I created an issue for the service that is throwing an error due to lerc decoding. In short, you are running into this issue because your server version is old (10.41). We have done our tests on 10.5 and later servers. If you upgrade your server, you will be able to use your services successfully in JS API 4.19.  

I modified your test app slightly so that the other two services are displaying. I will update you once we fix this issue. 

 

Hope this helps,

-Undral

LizEidsness
New Contributor III

Thank you for looking into this.

So you're saying it's both an issue with the version of our server, but also for the REST api?

0 Kudos
UndralBatsukh
Esri Regular Contributor

Hi there, 

Yes, the issue exists because of the combination of the version of your arcgis server and lerc decoder used for the older services in the JS API. With that, we fixed this issue at JavaScript API version 4.20. This version will be released late June 2021. 

Hope this helps,

-Undral

View solution in original post

LizEidsness
New Contributor III

That sounds good - just explicitly verifying - does that mean we will be able to use our current servers with 4.20 even if they are not yet updated?  

Also - does 4.next of the api include bug fixes or do i have to wait for the release to try it out?

0 Kudos
LizEidsness
New Contributor III

nevermind - i see it updated in your codepen sample.  Thank you!

0 Kudos