Basemap Gallery Update Issues

4093
16
12-22-2014 01:40 PM
StevenGraf1
Regular Contributor

I noticed 3.12 came with some new basemaps. 

1.  Terrain with Labels draws on top of my layers I have added to the map.

2.  If I switch to USGS National Map, it doesn't load.  After a little bit of switching between maps, my layers disappear from my map entirely and can't turn them back on with checkbox.

Here is an older unsecured application this is happening on.  I noticed on a version 3.8 AMD application I have it happens as well.

Anyone else experiencing the issue?

0 Kudos
16 Replies
TracySchloss
Frequent Contributor

I posted a similar issue (national map over https) and got NO responses.  I'm mandated to use https for everything and I can't get that basemap to load either. Occasionally I'll run into a site that doesn't support https.  That must be the case with the hosting server for that basemap.

If anyone knows of a workaround, I'd like to hear it too.  Ideally that basemap would be changed to allow https connections.

0 Kudos
HaroldBostic
Occasional Contributor II

you can use a proxy. That could be a work around

TracySchloss
Frequent Contributor

Adding a proxy and proxy rule took care of this issue for me.  However, changing every map in my production environment just so one new basemap works isn't realistic.

0 Kudos
NicholasHaney
New Contributor III

This is how I have fixed this problem in the past. If you look at your browser's console you should see a CORS related error. This is why adding the proxy rule fixes the issue.

0 Kudos
KellyHutchins
Esri Frequent Contributor

I took a look at the default maps in the Basemap Gallery and they are all available via https. Are you referring to National Geographic?
NatGeo_World_Map (MapServer)

https://server.arcgisonline.com/ArcGIS/rest/services/NatGeo_World_Map/MapServer/

If not can you provide more details about the basemap that is causing issues?

0 Kudos
StevenGraf1
Regular Contributor

The USGS National Map loads over http.  The rest work just fine.

This is the link it's trying to pull:

http://basemap.nationalmap.gov/arcgis/rest/services/USGSTopo/MapServer?f=json&callback=dojo.io.scrip...

0 Kudos
KellyHutchins
Esri Frequent Contributor

Thanks Steven,

I'll look into the National Maps issue.

0 Kudos