Switching to 4.24 won't load app, ProjectParameters.js error

151
3
Jump to solution
08-19-2022 06:37 AM
JustinKirtz1
New Contributor III

I'm trying to update my project to version 4.24 of the API but I'm getting an error whenever I try to load my app:

 

JustinKirtz1_0-1660916187202.png

This only happens when I try to switch to 4.24, if I put in version 4.23 or earlier my app loads just fine.

GIS Supervisor for Greenville Water
0 Kudos
1 Solution

Accepted Solutions
AnneFitz
Esri Contributor

Hi @JustinKirtz1 - all of the classes under the tasks folder have been deprecated since version 4.20, and were removed from the API at version 4.24 in favor of the new rest modules. Here's a blog that explains this change in more detail: https://www.esri.com/arcgis-blog/products/js-api-arcgis/developers/rest-is-up-to-the-task/

To get rid of this error in version 4.24, you will need to update your project to use esri/rest/support/ProjectParameters instead of esri/tasks/support/ProjectParameters

 

View solution in original post

3 Replies
ReneRubalcava
Frequent Contributor II

That module is now in the rest/support folder.

https://developers.arcgis.com/javascript/latest/api-reference/esri-rest-support-ProjectParameters.ht...

There should have been some deprecation messages for this in earlier releases 

 

0 Kudos
AnneFitz
Esri Contributor

Hi @JustinKirtz1 - all of the classes under the tasks folder have been deprecated since version 4.20, and were removed from the API at version 4.24 in favor of the new rest modules. Here's a blog that explains this change in more detail: https://www.esri.com/arcgis-blog/products/js-api-arcgis/developers/rest-is-up-to-the-task/

To get rid of this error in version 4.24, you will need to update your project to use esri/rest/support/ProjectParameters instead of esri/tasks/support/ProjectParameters

 

JustinKirtz1
New Contributor III

Derp, I didn't even notice that I was using that class in my code. Easy fix, thanks for the help! 

GIS Supervisor for Greenville Water
0 Kudos