Rendering Polygon That Spans International Date Line

454
7
09-24-2021 03:05 PM
AlexCopli
New Contributor

When I create a polygon or polyline that spans the international date line, it doesn't render correctly and instead goes around the other side of the world.

Is there a real fix for this? I'm surprised that ESRI can't just account for it within their SketchViewModel methods.

0 Kudos
7 Replies
JoseBanuelos
Esri Contributor

Hello @AlexCopli ,

Thanks for finding this bug. We are working to get a fix in for this real soon. Version 4.20 is not affected by this issue, however, we are trying to get a patch for this as soon as we can.

Thank you,

Jose

AlexCopli
New Contributor

@JoseBanuelos, Is version 4.21 affected by this issue? Is there a current workaround?

0 Kudos
RYANCARL
New Contributor III

@AlexCopli 
Looks like the problem is on version 4.21 as well.

@JoseBanuelos 
Can you please let us know if there is an ESRI recommended workaround for this issue? A vast majority of the data I work on is in the pacific ocean.

Screenshot (20).png

JoseBanuelos
Esri Contributor

@RYANCARL ,

We are working on a patch right now, so no workaround will be needed for 4.21. I will post once the fix is in.

Thanks,

Jose

RYANCARL
New Contributor III

Great news.

Looking forward to getting a fix in for this. We are very close to releasing this software and need to have this issue taken care of.

 

Thanks.

JoseBanuelos
Esri Contributor

@AlexCopli 
What version did you find this issue in? This was reproduced only in 4.21. We are trying to get a patch for 4.21. If you reproduced in an earlier version, can you send repro app and repro steps? 

0 Kudos
JoseBanuelos
Esri Contributor

@AlexCopli @RYANCARL ,

This issue has been patched and no longer reproducible in version 4.21. You can test with the following sample:

https://developers.arcgis.com/javascript/latest/sample-code/sandbox/?sample=sketch-geometries

Please let me know if you are still seeing this problem.

Thanks,

Jose