No edits ('adds', 'updates' or 'deletes') were specified

575
0
08-22-2019 09:47 PM
PAUL_RICHARDSDHANDAPANI_C
New Contributor

Hi,

 

Good day all !

 

Need your inputs/comments in troubleshooting an issue while applying edits on feature layer using editor widget using ArcGIS Editor Widget (3.10).  The code which we used was working fine until last month and suddenly it stopped working recently.  Please find below the problem description and troubleshooting steps which we performed.

 

Problem description:

Unable to perform edits on feature layer using editor widget from web map application.  We are using default esri editor widget (3.19) and the version of ArcGIS is 10.5.  There is no code error since it was a working code and no compile error as well.   The issue is at the time of double clicking and closing the edit operation.  We have traced the network traffic using browser and able to get the request body as an encrypted JSON string which is valid, however the response body displays "Unable to complete operation. No edits ('adds', 'updates' or 'deletes') were specified".   By default feature service should allow edits on the layer, but it is not behaving like that now!

 

Troubleshooting steps:

  • Verified the feature service whether CRUD operation is enabled and confirmed the same.
  • Analysed whether the map document is valid and found no issue
  • Debugged the code and found that it is valid code
  • Used browser F12 to debug the events fired and confirmed that there is no console error log or other logs.
  • Traced the network using browser tool and confirmed that the new edited geometry is parsed properly and sent to ?applyedits methods on the feature service.
  • Tried testing using single feature layer instead of multiple feature layers and the issue is same - Unable to save/apply the edits
  • Tried versioning the data too (which is not required), but still issue persists

Code:

 

Error:

 

 

Findings: 

After thorough investigation I decided to check the POC which we showcased to the users earlier and found that it too fails to save the edits in feature layer.  So I decided to look on the windows patch level updates.  The recent patch which got installed was Windows Patch (KB4512517) on Aug19.  Hence, I selected a different server without this patch and tried publishing my feature service in that server and consumed in my web application.  Surprisingly, in my first attempt the edit operation successfully completed without any error !!!

I am still unclear whether this windows latest patch is causing the issue.  Hence, I decided to enable all server level logs in my ArcGIS Manager and didn't get any logs apart from the INFO request.

Next step:

I am now trying to find how internally the Feature service is working to save the edits on feature layer. I am trying to figure out all log level information where it logs the sequence of events starting from Request received, processing, completed etc...  Unfortunately, I am not able to enable and see all events which are happening in the back end inside my ArcGIS Server while serving the request.

Could you any one share your thoughts/suggestion in the case on how I can trouble shoot further.

Regards,

~Paul

0 Kudos
0 Replies