Legend label showing "Override", not customizable?

06-18-2020 03:48 PM
Occasional Contributor

My web mapping application uses a custom print task, print service, and associated MXD to create a PDF of the map for users.  I have a legend in MXD - it works fine, but upon adding my graphics layer to the list of Layers for the Legend (using the legendLayers property in the layoutOptions for the Print Template), the label next to the symbol says "Override 1" (see attachment).  I can change the text above the symbol ("Selected Structure"), however I can not figure out how to change the piece of text to the right of the symbol. 

I'm using the JS API version 4.12.   I tried rolling back to 4.5 but that didn't help.  I also tried upgrading to 4.15 but I'm going to have to revise a bunch of my code for that version to work. 

I found this two-year-old post: [Override-item-names-in-legend-print-task]...  But it sounds like the answer was to roll back the JS API version.  Has there been any new development on this?

0 Replies