Circle rings aren't being created properly in 4.12

416
3
Jump to solution
08-14-2019 05:18 PM
ChristopherHollis
New Contributor

This doesn't work in 4.12:
https://jsfiddle.net/qgw6tj3y/
It does in 4.11:
https://jsfiddle.net/yxkeo75f/

4.12 made some of the following changes:

Breaking changes
- "As part of performance optimizations, incorrect polygon geometries that don't follow the expected clockwise order, no longer display. Polygon rings should be clockwise, with counterclockwise rings considered holes."

Bug fixes and enhancements
- "BUG-000117587: Circle.clone() now works as expected."

Did it break something? Or is there a new way it needs to be done? It creates only part of the rings in 4.12.

There is also a circle related bug here related to radius:
https://community.esri.com/message/862458-bug-in-412-js-api-circle-no-longer-has-radius-property

Maybe this issue is related.

0 Kudos
1 Solution

Accepted Solutions
UndralBatsukh
Esri Regular Contributor

Hi there, 

Thank you for reporting this issue. I am able to reproduce the issue and confirmed that it will be fixed at version 4.13. 

-Undral

View solution in original post

3 Replies
UndralBatsukh
Esri Regular Contributor

Hi there, 

Thank you for reporting this issue. I am able to reproduce the issue and confirmed that it will be fixed at version 4.13. 

-Undral

ChristopherHollis
New Contributor

Thanks. I'll keep the scripts that use this type of circle at version 4.11 or lower for now.

0 Kudos
BenElan
Esri Contributor

On line 33 comment out 

"geodesic": true,

This is similar to a few equivalency bugs I logged for 4.12

0 Kudos