Bug in attributeInspector (or potentially dijit buttons)

3832
2
Jump to solution
07-30-2014 10:23 AM
BillyYancey
New Contributor II

There is bug in the "Using the attribute inspector" presented in this page. Actually, it seems to be a bug either with the attribute inspector itself, or even the dijit button.

Here is the description: When checking out the live sample, after opening the attribute inspector by clicking on one of the features, hover over the Delete and Save buttons. You notice that the area over which the buttons get highlighted (and respond) are not the visual area of them.

Any thoughts?

 

Using the attribute inspector | ArcGIS API for JavaScript

0 Kudos
1 Solution

Accepted Solutions
BillyYancey
New Contributor II

I actually figured that this is a CSS bug, and here is how I patched it for now:

attInspector.deleteBtn.domNode.classList.remove("atiButton");

The problem is that in the the CSS class atiButton has a fixed 16px size (geared towards the navigation buttons) and the delete button should not inherit from it, or better yet, the class should change and a new atiNavButton should have the fixed size, etc.

View solution in original post

0 Kudos
2 Replies
TimWitt2
MVP Regular Contributor

Yeah there is something weird going on. When I comment out the save button, everything looks fine. There seems to be a placement issue.

0 Kudos
BillyYancey
New Contributor II

I actually figured that this is a CSS bug, and here is how I patched it for now:

attInspector.deleteBtn.domNode.classList.remove("atiButton");

The problem is that in the the CSS class atiButton has a fixed 16px size (geared towards the navigation buttons) and the delete button should not inherit from it, or better yet, the class should change and a new atiNavButton should have the fixed size, etc.

View solution in original post

0 Kudos