HELP!!! Change arcgis server url from localhost:6080 to an arcgis url

334
2
05-16-2020 12:07 PM
MedMZOURI
New Contributor III

hey guys I have a problem I want to change my arcgis server url from localhost:6080 to an arcgis url..because when I publish my geoprocessing services and I want to add a custom widget in web appuilder I can't add it . I can add some public geoprocessing services of other people who have a URL different from localhost:6080..that"s why I want to change my server url from localhost:6080 to an arcgis url.. 
PS: I don't have Portal for arcgis..or rather I have installed it but I don't have license for it

0 Kudos
2 Replies
MichelleBrake
New Contributor III

You need to configure your ArcGIS Server domain and make sure that you have configured the Web Adaptor. Since you are using ArcGIS Online, don't worry about the Portal part as you don't have the licensing to fully set it up. While you should have a CA signed certificate for the domain you can use a self-signed if needed. Here are some resources from Esri's documentation to help you with the Web Adaptor and domain configuration:

An overview of implementing ArcGIS Web Adaptor with a server site

Enabling SSL using a new CA-signed certificate

Configure ArcGIS Server with a new CA-signed certificate

Understand SSL Certificates for ArcGIS Server and Portal for ArcGIS

If those resources don't help, I would recommend posting your question to the ArcGIS Enterprise community to help get more eyes on your question. This group is for the product Admin Tools by GEO Jobe. 

 

Thanks,

Michelle
geojobe.com

MedMZOURI
New Contributor III

Thanks Michelle for your continuous help..actually I solved the problem related to publishing services and running them on web appbuilder..I don't have this problem anymore (thanks to web adaptor and all what you have just mentioned about SSL certificates) But now I got a new problem which is I created a model and I run it with no error both in arcgis desktop and web appbuilder, my model creates a feature ( a square given XY coordinates) and inserts it in a layer , it runs perfectly in arcgis desktop, but in web appbuilder no square is created
Thanks Michelle

0 Kudos