Geocoding: Match out of range

4773
14
11-18-2019 07:33 AM
JoeBorgione
MVP Emeritus

ArcGIS Pro 2.4.0

What is the logic of the 'Match out of Range' setting in a locator created with the create locator tool?  By default it is set to Yes.

I geocoded a table of addresses against a multi-role locator that has Address Points and Street Address roles. When I rematch, there are no candidates found. However, with the same locator active in my map, I can get get a 98.9 score on an address that does not exist with the Locate tool:

Eric Anderson

That should just about do it....
Tags (1)
0 Kudos
14 Replies
EricAnderson17
Occasional Contributor

Hi Joe,

The "Match out of Range" option allows you to still get a successful match even if the address is out of the designated house number range but still falls within a reasonable threshold. 

Tips for improving geocoding quality—ArcGIS Pro | ArcGIS Desktop 

This would most likely require a little investigation. I tested this out on my end and can confirm that a house number which falls out of range is successfully returned as a candidate from both the Locate pane and Rematch Addresses pane. 

Have you tested this with other addresses within the same locator? What about with a different locator all together? 

Best regards,

Eric

0 Kudos
JoeBorgione
MVP Emeritus

I just don't see the point inn matching an address that the data does not support. But from our other thread, it sounds like I can suppress that...

That should just about do it....
0 Kudos
EricAnderson17
Occasional Contributor

Right, the documentation I sent above makes a pretty good use case - "This will ensure that you don't miss a potential match because the data isn't 100 percent up to date." However, if you are good about keeping your reference data up to date, then keeping the "Match out of range" option set to False/No should continue to work well for you. 

0 Kudos
JoeBorgione
MVP Emeritus

Ah-ha!  Happy to say that  I'm spoiled with very good data to work with!

That should just about do it....
0 Kudos
FrankMatzen
New Contributor III

I have an ArcGIS Pro locator where MatchOutOfRange=false. I published it to ArcGIS Server. When I send this request to the GeocodeAddresses API, it matches to a street side with no address range. How can I fix this?

request=

{"records":[{"attributes":{"ObjectID":1,"Address":"922 FRONT ST","Postal":"13905","City":""}}]}

reply=

address: FRONT ST, 13905
location: {"x":-75.8962068584517,"y":42.15390414154837}
score: 93
attributes: {"ResultID":1,"Loc_name":"NYStreets90","Status":"M","Score":93,"Match_addr":"FRONT ST, 13905","LongLabel":"FRONT ST, 13905","ShortLabel":"FRONT ST","Addr_type":"StreetName","Type":"","PlaceName":"","Place_addr":"FRONT ST, 13905","Phone":"","URL":"","Rank":20,"AddBldg":"","AddNum":"","AddNumFrom":"","AddNumTo":"","AddRange":"","Side":"","StPreDir":"","StPreType":"","StName":"FRONT","StType":"ST","StDir":"","BldgType":"","BldgName":"","LevelType":"","LevelName":"","UnitType":"","UnitName":"","SubAddr":"","StAddr":"FRONT ST","Block":"","Sector":"","Nbrhd":"","District":"","City":"","MetroArea":"","Subregion":"","Region":"","RegionAbbr":"","Territory":"","Zone":"","Postal":"13905","PostalExt":"","Country":"","CntryName":"USA","LangCode":"ENG","Distance":0,"X":-75.89620685845176,"Y":42.15390414154823,"DisplayX":-75.89620685845176,"DisplayY":42.15390414154823,"Xmin":-75.89720685845177,"Xmax":-75.89520685845176,"Ymin":42.152904141548234,"Ymax":42.15490414154823,"ExInfo":"922","Ref_ID":90973125}

0 Kudos
ShanaBritt
Esri Regular Contributor

@FrankMatzen ,

The behavior you are seeing, a match to StreetName Addr_type, is expected behavior when Match out of range is false. If you only want matches to PointAddress or StreetAddress level or Street Intersections only, you need to disable the StreetName category in the locator properties > Geocoding Options > Match Options under Categories to support before publishing the service. You will be able to test this in the Locate pane in ArcGIS Pro before publishing the locator.

0 Kudos
FrankMatzen
New Contributor III

Thanks @ShanaBritt. I will test this today.

0 Kudos
FrankMatzen
New Contributor III

I disabled the StreetName category, but this did not fix my issue. The address is matching via the StreetAddress level. I remember with ArcMap locators, I was able to increase the score penalty applied to a geocode when the street name spelling was off. I did this inside the locator template. Is there anything similar that I can do inside an ArcGIS Pro locator, to force addresses not to geocode if the ZIP Code is not a perfect match, by assigning it a large score penalty?

0 Kudos
ShanaBritt
Esri Regular Contributor

@FrankMatzen There is no spelling sensitivity setting for the locators created with the Create Locator tool and there is not modifiable locator style template for the locators created with the Create Locator tool in ArcGIS Pro.

I see in the example you provided that the StreetName match had a score of 93, what as the score of the StreetAddress candidate after disabling the StreetName category? You can increase the 'Minimum match score' setting in the Match Options section of the Geocoding options in the locator properties, this will affect batch geocoding (geocodeAddresses) results. Maybe try increasing the score to 95 or higher and testing in ArcGIS Pro before publishing as a service. If you increase the 'Minimum candidate score' setting this will affect findAddressCandidate results. If you do test the behavior in ArcGIS Pro using the Locate pane I would set both Minimum candidate and Minimum match score settings to the same value.

Is the locator you are using a single role locator, multirole locator or a composite locator?

0 Kudos