rastrauch

Tips and Observations for getting Web AppBuilder -  Developer Edition Installed (updated 8/26/2018)

Blog Post created by rastrauch Champion on Jan 14, 2015

Tips and Observations for getting Web AppBuilder -  Developer Edition Installed

updated 3/26/2018 
version 2.7 (January 2018)    Web AppBuilder for ArcGIS (Developer Edition) | ArcGIS for Developers 

 

My other WAB related blog posts:

 

WAB  now 2.7 available (January 2018)  

   Web AppBuilder for ArcGIS (Developer Edition) | ArcGIS for Developers

 

Update Summary:

 

With many of us having issues with getting the Web AppBuilder (WAB) developer’s edition set up correctly, here are a few tips and solutions I have found, both to help others, and for me to find again (!). Some tips are taken from other threads, which I will link to if I can find them again.  I will also add some of my observations, assumptions, and understanding at the end of the doc…. comments are welcome, and I will update if necessary.

Various errors people have received are

  • issues with nodejs (only what I have come across, so far)
  • what to do about the appID on start up,  --See step 3 below
  • what to do if you messed up the appID and now get a 200 error,  - See “Starting (semi) from Scratch”, or you can look at the 10/15/2015 tip above.
  • what to do it getting a 400 error – See step 3h and 3i, talking about registering your machine

This is not an all inclusive list, and I will try to update if other solutions are given.  Steps:

  1. Download the software (.zip) from Web AppBuilder for ArcGIS (Developer Edition) | ArcGIS for Developers  recommend copying it to a new folder.
  2. Expand the .zip.  Recommend letting it create the “arcgis-web-appbuilder-2.X” folder…may vary depending on version
  3. I recommend manually creating the app on AGOL before you fire up WAB (sorry, not familiar with Portal) before firing up WAB.
    • Instructions in Help for creating the AppID are a bit better than in previous versions.  Link is included for your convenience: Get started—Web AppBuilder for ArcGIS (Developer Edition) | ArcGIS for Developers
      • 12/14/2016  I just used the help above, and hints from my notes, to create an AppId using Portal 10.5 (pre-release).  The help has not been updated for the new Overview-Settings tabs after the initial screen, so the setup may look a little diferent.
    • NOTE: can use the same ID that was created for WAB 1.0/1.1 etc. in current versions (assuming machine is "registered")
    • First, login to your AGOL account (I assume this must be organization account, not personal or developer, but will need to verify)
    • Go to “My Content
    • Pull down “Add Item” and select “An Application”  
    • For URL, believe it or not, the server/machine-name didn’t seem to matter much for me, (since it still worked when I had a typo), however, it is suggested that you enter   http://<your machine name>:3344/webappbuilder
    • For Title, tutorials say “Web AppBuilder for ArcGIS”, but this can be something more personal, e.g. “Rebecca-WAB” or whatever makes sense to you.
    • For tags, tutorials say “Registered App for OAuth”, but I think this is just the default, and can be different.  I know when searching this tag on AGOL, you end up seeing everyone that left it as the default.  I’m not sure if this is a good thing or not. (new graphic to reflect updated look in AGOL)

    • After you hit ADD ITEM, the item information page should open for this new app.
    • 12/14/2016  This is where is looks a little different. The next steps are found in the "Settings" tab
      • NOTE: I did this using Portal 10.5 pre-release, but the AGOL tabs are the same to the best of my knowledge....but didn't create an AGOL appid today
      • NOTE:  Mentioning this here so it doesn't get lost....make sure to check the box to "Prevent this item from being accidentally deleted"  !! You can do this at this stage, or wait until you are done with the registering, but good safetly measure.  If you do need to delete this appID  at some point, you will have to uncheck the box.
      •  --> Just noticed in the Settings tab, click on the "Web Mapping Application Settings", it brings you down to the Register key area for next step >>
      • At the bottom of that tab, you will see the Register button
      • which should now get you to the same place as you need below.
    • Select REGISTER.  In the “Redirect URI” box, add an http and https version for your machine
      • http://<machinename>
      • https://<machinename>
        • HINT: after you hit “ADD” you can’t grab the string to change the http to https:, so select and copy the string (Ctrl-A, Ctrl-C) before hitting ADD so you can past and modify the second entry.
        • HINT 2: for our location, we had to include domain info so the computer name  was <machine name>.<full domain>
        • HINT 3: If you want to use multiple machines for development, you can enter additional machine names now or later.
        • HINT 4 added 6/23/15: by Leighton Dalmasse  when configuring Web AppBuilder Developer Edition 1.x with Portal 10.3.....or AGOL --- i.e. HINT 2 above)
          • The structure of the Redirect URIs is dependent on if your server is setup in either a Domain or Workgroup. To determine the setup, go to your server’s “Control Panel\System and Security\System” (or right-click your Computer and get properties in Windows File Explorer) to view basic information and note the “Computer name, domain, and workgroup settings”, if it is setup on a Domain you will see a domain, if it is setup on a Workgroup you will see a workgroup. For each configuration the Redirect URI structure should be as follows (to cover all of your bases it is probably safe to include both but I have not tested this):

Workgroup:

- http://<machinename>

- https://<machinename>

Domain:

- http://<machinename>.<FullDomain>

- https://<machinename>.<FullDomain>

 

Sample shows registering two different machines with http and https  with <machinename>.<FullDomain>

    

Suggest to add HINT #5: If having issues and still getting the WAB redirect_uri error 400 error "Double check your computer name and pay close attention to spelling."

HINT #6 added 2/15/2017: Tip for "Error 400  Invalid redirect_url" : Make sure your machine name is not longer than 15 characters, if it is, the url will be truncated. Change your machine name and run thru process again.  (from Can I use Web Appbuilder Dev Edition during a Free trial of ArcGis? )

 

    • When done, hit REGISTER   which will bring you back to the details page, with the App Registration info displayed.   The App ID that you can use when starting WAB for the first time will be shown.  Copy this (and/or write it down)
      1. HINT: if you already exited the details page, you can go back to the page through My Content  and then select REGISTERED INFO  (in the Setting tab) to see the info again.
      2. HINT 2: to add/delete additional computers, select EDIT and UPDATE
      3. HINT 3: I recommend checking the “Prevent this item from being accidentally deleted” in the Properties section (toward bottom when in EDIT, i.e. select the EDIT button at top of page first) Settings->General Settings (near the top) once you have it set up.
      4. HINT 4: if you want to disable this app, for whatever reason, you can UNREGISTER APP which will disable the <machines> from using this app, i.e. disabling the WAB developer this appid is pointing to it.
      5. HINT 5: Other thread that may help Migration Migraine  (correct answer from Jake Skinner )

 

  • Step 4 - With AppID, you are now ready to start up the WAB.
    1. Go to the folder with the expanded/extracted WAB software, double click Startup.bat.  This should open a command window, show the ports and a list if “inserts”   (note: if next custom widgets added later, will see more inserts)


then if all works, your default browser (I use Firefox) should open and WAB should fire up.  If not…

 

  • HINT 1: Typically, even if installed and registered correctly, the first time I run WAB for the day (or browser session), I have to close the command window, and double-click on the startup.bat again….then it usually opens. [one of my machines requires this, the other fires right up]
    1. If the WAB setup opens properly, you should see something like the graphic below.  In the first box, put the URL to your AGOL or Portal, in the second, you AppID from Step 3 above.
    2. After hitting Continue, you will next be prompted with “Request for Permission” for your AGOL username to access the application you created or accessing (from Step 3 above).  Notice that the application you created will be listed
    3. Once you either enter you credentials (if not already logged in) or “APPROVE”, the application will open and you should be ready to go.
  • Hint 2: Problem with specify my wab developer url and app id     try creating a new user account on AGOL and follow the procedures above...see if that resolves the issue.

 

Starting (semi) from Scratch

If for some reason you don’t get the WAB set up correctly the first time, (maybe because you started and exited because you didn’t know what to put int for the AppID)  and therefore it:

  1. it never prompts for the appID again, or
  2. the startup is listening for the ports, but doesn’t list the “insert” statements, fires up the WAB page, but it is blank

The easiest solution I have found is to (close the command window and the bad WAB in the browser, if applicable, then) delete the expanded “arcgis-web-appbuilder-1.0” folder (may work to rename?) and to re-extract the .zip.  Then start with the Startup.bat again with your AppID ready (Step 4 above).

 

Observations and my initial understanding, resources, etc. (to be updated as needed)

  • GeoNet groups/spaces/places/threads you should join or be “following”:
  • There are MANY custom widgets being create and updated (many from Robert S --thanks!) I keep track of these, as much as I can  here: Web AppBuilder Developer Edition - Resource List (updated 3/26/2018)
  • Other sources….
    • Comprehensive install document with graphic by TAPAS DAS Web AppBuilder   much more than his blog title has you believe.
  • Popular questions (many threads, with slight variations, for each question):
  • My observations:
    • The AppId when first starting is the most confusing, and finding clear instructions for setting up the AppId ahead of time (including mine) are hard to find.
    • I’m not exactly sure what registering the WAB with the AGOL application and AppID really does, although I know it ties it too AGOL. Also, it control whether a computer has permission, via registration with the AGOL application.  I know it has to do with OAuth2, but I’m not a security expert.
    • I asked the question Is it better to share "application" registered in AGOL between WAB-dev edition developers, or separate?  and have decided:
      • A WAB folder (and startup.bat file) are pretty much linked to on AppID – although there are ways to shift or change which one.
      • Each user should have their own application/AppID created by them, in their own My Content
      • Multiple machines for one user can be registered to the same AppID, if desired. The WAB stores the applications being created in the local drive, so these are not necessarily shared between machines…although I think they could be setup to work that way.
      • One machine could be registered to more than on AppID, if desired and if multiple WAB startup folders exist.
  • Portal - question and answer from comments below from Seema Joshi  (question  "Has anyone tried configuring Web Appbuilder (Developer Edition ) with Portal 10.3 configured locally - behind firewall, not in Public domain ? It works fine with Webmaps configured with AGOL / Organization Account OR PFA in Public domain, but we are experiencing issue accessing Webmaps having Map Services published in local Server. It is accessing Webmaps and displaying basemap layers with correct extent but local Map layers are not displaying."    Solution ( also from Seema):

 

      Please try following :

  • Change your local Server Security permissions from HTTP Only to HTTPS Only using ArcGIS Server -> Admin -> Security -> Config -> Update option as per snapshot below.
  • Stop & Restart your local Server.
  • Add Services to your Web Map as SSL with domain name eg. https://lap-ggn-seemaj.in.niit-tech.com:6443/arcgis/rest.........
  • Save & Share WebMap
  • Try Web Appbuilder using AGOL OR Portal for ArcGIS 10.3
  • .......will format better and add image when on a better machine mid March ....see comments below until then.  Thx -Rebecca

        

 

That’s about for tonight.  I hope this helps someone…. at least I should be able to find it again.

 

--Thanks for all the kind words of appreciation for this and my other rather messy WAB blogs. It's nice to know they are helping others, and that I still know where to find my notes!  8/27/15

Outcomes