PBurmanesriaustralia-com-au-esridist

GeoEvent Processor won't start up ... Help!

Blog Post created by PBurmanesriaustralia-com-au-esridist Employee on Jul 15, 2014

A number of people here in Australia are getting their hands on GeoEvent Processor, the ArcGIS Server extension, for the first time.

 

During my time in Support I've assisted a number of people to get their GeoEvent Processor running, and have found that a simple 4-step process is generally all that is required, which I've included below:

 

1. Stop GeoEvent Processor & ArcGIS Server Services, from Windows Task Manager.

 

gep-blog-01.png

 

 

2. Traverse in Windows File Explorer to the C:\Program Files\ArcGIS\Server\GeoEventProcessor\ folder and locate the .lock file and delete it, then traverse to the Data folder (found in the same location, but explicitly: C:\Program Files\ArcGIS\Server\GeoEventProcessor\data) and delete the entire contents.

 

gep-blog-02.png

 

3. Add the user running the ArcGIS Server and GeoEvent Processor Services (nominally: arcgis) to Administrators group on the server where ArcGIS Server and GeoEvent Processor is installed.

 

gep-blog-03.png

 

4. Restart your ArcGIS Server and GeoEvent Processor services as shown in the screenshot in Step 1 ... and I hope you are back up and running, 99.9% of users report success.   

 

The above process assumes that you've correctly applied your license file, and doesn't account for issues where the license is the cause of the issue, slight disclaimer there!

 

Well that's all for now folks, hopefully more to come....

 

Paul Burman

ArcGIS Server from Down Under

Outcomes