Admins libs

Blog Post created by FrancisBase on May 22, 2018

Here is a contribution for working out a somewhat bug that can occur for Windows 10 / Server admins of ArcGIS Enterprise.


Using an approach of Problem - Etiology - Symptoms for diagnostic and after the intervention, as used by most management processes from healthcare to finance endeavours.


Since this wasn't found neither in forums, or esri awesome documentation, here is contribution:

By going or doing either of the following:


> to https://<fqdn>:2443 (webadaptor URLs) it will display the following error:
Error: Unable to perform this operation because the GIS Server site registered with this data store is not available.. Extended error message: Could not connect to server on machine '<FQDN>.MSHOME.NET'. ArcGIS Data Store or ArcGIS Server on that machine may not be running or the machine is not reachable at this time.


> https://<fqdn>/<webadaptor_server>/admin/machines/<fqdn>/sslcertificates/

will display three certificates instead of two (one for portal and other for server)
having the selfsigned certificate the following corrupted entry:
in Server Portal it will corrupt the existing selfsigned certificate - default for the following content:
Subject Alternative Names:
DNSName: <fqdn>.MSHOME.NET
instead of:
Subject Alternative Names:
DNSName: <fqdn>

> C:\Program Files\ArcGIS\DataStore\usr\logs
it will display an <machine> suffix folder

> www.<fqdn>.com\webadaptor_portal\
it will redirect to <fqdn>

> C:\Program Files\ArcGIS\DataStore\tools and run changedbproperties --store tileCache --enablessl none
it will say Machine <fqdn> encountered an error

Datastore is now focused in a different pseudo machine, the problem is ICS service, that corrupts the DNS adding a suffix to machine name <fqdn> named, and rewrites sslcertificates, server configurations and so on.

This is not so easy to fix because ICS even disabled is required by:
- Hyper-V which is a windows feature used for Virtual Machines and container solutions like Docker
- HV and Host Server Network service related with virtualization
- Windows Defender Firewall
- Internet Connection Share
- run ccleaner
- disable the following services:
> all Hyper-V named services
> HV named service
> Hosted Network Server
> Windows defender firewall if ICS gets automatically working
- Go Control Panel\Network and Internet\Network Connections > right click in internet active > properties > Sharing tab > Uncheck Allow other network users to connect through this internet connection
- Go Control Panel\All Control Panel Items\Network and Sharing Center\Advanced sharing settings > turn off bugged related options
- Control Panel\All Control Panel Items\Network and Sharing Center and if an unidentified default switch is on it may be the culprit so how to fix:
in power shell: "Get-HNSNetwork | Remove-HNSNetwork", notice it will take out the default switch
- in cmd: ipconfig /release and ipconfig /renew restart and is working as detailed here
- restart machine


Done enjoy!