AnsweredAssumed Answered

Iterator not working

Question asked by Curtis_Lisle_LearnArcGIS on May 20, 2020
Latest reply on May 31, 2020 by curtvprice



I am currently attempting a Least Cost Path analysis, specifically, a "From everywhere to everywhere model".


Cost raster = Slope_Raster

Surface raster = 0 value extracted_DEM

Vertical Factor: Tobler Away


To achieve thus multi-path approach, I made my destination (which, according to this model, will also become origins) points through the Fishnet tool, settling for a 25kmx25km grid. I then put this fishnet through "Split by attributes" to acquire individual points that I could run separately through the Path distance tool. I then merged these points so that I could run them collectively through "Iterate Feature Selection" in Model Builder. 

It is at this stage that I encounter a problem. When the Model runs, it only iterates through the first three points of the merged points. I have tried selecting different fields, and I have even tried to achieve an iteration through a separate tool ("Iterate feature class"). No matter what variation I try, the same issues arises; the model only create paths for the first three points out of the entire 83 point feature.

I am at a loss as to what to do, and cannot seem to find what is causing this error.

Thank you in advance.

P.S. I know this method of achieving multiple pathways is possible as I used the same model building technique in ArcMap 10.7.1 and it worked (However the processing was incredibly slow).