AnsweredAssumed Answered

ERROR 001566: when trying to Clip

Question asked by ryotaka on Mar 16, 2019
Latest reply on Jul 8, 2019 by jborgion

Hi everyone,


When I tried to clip raster with several polygon shape files, I observed that some shape files worked, while some gave me an error (Error 001566). The error message indicates that input polygon may not be within raster layer. However, by checking the map, the failed polygon layer is inside of raster layer, so it seems just fine.

What makes me confuse is that some input polygon worked just fine. I don't see any difference between the worked polygon and failed polygon.


When I checked the error 001566 from following link, it may be due to overwrite error.

001566: Service overwrite error: failed to delete the service.—Help | ArcGIS Desktop 

However, I'm not deleting or overwriting any files, just generating new file by clipping.

And it doesn't make sense because some input polygon files are working.


When I searched the solution, I found the following link.

Error 000229 when trying to Clip 

Although the error number is different, it may be causing the same error.

One person responded that it worked by turning off background processing.

However, since I'm using ArcGIS Pro, there is no option to change the setting of background processing.


I'm wondering if anyone knows how to solve this issue with ArcGIS pro (now, I'm regretting to switch to pro).