AnsweredAssumed Answered

python versions

Question asked by jwolff on May 13, 2019
Latest reply on May 13, 2019 by mvolz47

We have several nightly .py geoprocesing scripts running on a dedicated scripting server via scheduled tasks.  These scripts are all written in Python version 2.x.  Only ArcGIS Desktop 10.5.1/Python 2.7.13 are currently installed on this server.  We are considering installing ArcGIS Pro 2.3.2 on this machine as well because users are beginning to develop scripts in Python 3.x.  A couple questions:

1) Will installing Pro interfere with the existing Python 2.x scripts?

2) How will Python 3.x scripts run correctly?  As scripts always start simply with ‘import arcpy’, do all scripts need to be modified to point to the specific 2 or 3 .exe?

Thanks

Outcomes