azatrain

IWA Portal Login and Feature Service Access

Discussion created by azatrain on Mar 14, 2019
Latest reply on Mar 29, 2019 by azatrain

We've got an IWA Portal setup in house and we are working on getting our iOS Runtime Xamarin Forms application to work properly with it.  We have been using oAuth based authentication for years and now have customers implementing IWA based Portals and need to support that.  

 

To get the login going I am using the ArcGISNetworkCredential.  When the authentication challenge is issued against our IWA portal we pop up a home grown username/password form, take that information, create the ArcGISNetworkCredential and login to the portal accordingly.  I've got that all working well.

 

We have a couple of tools that utilize feature services to create offline geodatabases to support field work.  When I try to generate those offline geodatabases using the ArcGISNetworkCredential I am getting an error that a token is required.  Makes sense.  Problem is the ArcGISNetworkCredential does not have a token associated with it. 

 

I then switched gears and attempted to use the ArcGISTokenCredential for everything - logging into the portal and generating geodatabases from feature services.  No luck there - could not get that to work for logging in.

 

I've been through the multitude of online documents referring to integrated windows authentication implementation and have used a lot of code examples in there within our app.  I have not found anything that addresses our particular scenario though.  I feel like I'm close on this and am missing a small piece of the puzzle.

 

Can someone point me in the right direction?  Thanks!

Outcomes