goober0

AGOL User Management - Automatic Group Assignment

Discussion created by goober0 on Feb 19, 2019

Are any other AGOL org administrators noticing inconsistent results when assigning members to groups via invitation settings (enterprise or otherwise)?

 

This is a routine part of our workflow for supporting AGOL use in our courses at CSU, Monterey Bay:

  1. A group is created for each course section needing AGOL
  2. The instructors provide email lists for each of their sections
  3. The AGOL admin invites members using the email list, and assigns the appropriate group(s) as well as enabling ESRI access
  4. Students (hopefully) respond to the invites before they expire, and get assigned to the group for their section automatically

At least that's how it is supposed to work. Lately, I've seen numerous cases wherein the group assignment fails. I have not seen a pattern yet. We typically assign at least two groups, a "New Users" group that is just for tracking purposes, and the course section group the student needs to be a member of. The same invitation group assignments are applied to the entire list for a particular course.Sometimes it works as specified, but with annoying frequency one or both group assignments fail, and the user must be manually added to the group(s). The failures are not specific to a particular list/batch of invites or group.

 

Along with the fact that AGOL does not reconcile invites against existing members (a matter for another discussion), this is making user management even more of an onerous chore than it has been in the past.

 

So, is anyone else seeing similar issues?

 

Pat Iampietro

CSU, Monterey Bay

Outcomes