AnsweredAssumed Answered

Issues with feature layers in model builder

Question asked by nbanerjee on Oct 12, 2016
Latest reply on Jan 23, 2019 by curtvprice

I have been having increasing issues model builder that utilizes model parameters as inputs and feature layers in an existing ArcMap table of contents.  I models run successfully for a while, but then if I change the underlying input layers at all (even if if has no impact on the model process), it acts flaky.  For example, I have a simple model that simply calculates three fields in an existing feature class that I have loaded in ArcMap.  The input feature layer is exposed as parameter, but I have a default value set.  It worked fine may times, but now when I run it, I get a message that there are no records in the table (even though there are).  To make it work now, instead of using default or picking from list of ArcMap TOC items, I have to point the input to the feature class by loading the feature class directly in the tool interface (i.e. hitting the little folder icon and navigating to the where feature class is stored).  If I do that it works fine. he attached images show the simple model, model interface, and message I am getting.

 

This is happening in other cases where I have more complex models that have input as parameters, and that have pick lists of fields based on the selected feature class.  Im finding if I add fields to a certain layer and then run the model and pick the feature class, it does see the new fields.

 

It seems like something about the models is storing memory of previous runs related to feature layers loaded in the ArcMap document. I have tried closing out ArcMap sessions, cleaning temporary file locations, using MXD doctor, and similar.

 

Any input on what may be happening would be greatly appreciated!

 

Thanks

Neal

Simple Model

Simple Model Interface

 

Simple Model Error

Outcomes