AnsweredAssumed Answered

How to publish a custom WAB app to Portal?

Question asked by Cimejes on Apr 24, 2018
Latest reply on May 21, 2020 by miribsystematics-co-il-esridist

Hello. Using Web AppBuilder Developer Edition, I put together a custom web app that I would like to publish to my organization's Portal, but I'm not sure how exactly to do so. I've read through the guide and a number of threads here on GeoNet, but I'm still not sure how to properly publish the app. I'm a novice when it comes to web development and servers and the like. Step 2 in that guide ("Deploy it on your web server") is a bit short on details, and I'm not sure if the instructions in this thread apply in my situation, since I'm only looking to publish the app on Portal for people within my organization to access.


Through some trial-and-error (and referencing documentation such as this), I found that in Portal I could view a template I downloaded by dropping the extracted folder in Portal's "apps" directory on the server and adding an application with its URL (e.g. https: //<server name>/arcgis/apps/BasicViewer/index.html) in Portal's web interface ("My Content"). Following the same basic process, I tried to publish an app that I created in Web AppBuilder Developer Edition. What I did was:


Downloaded the app from the Web AppBuilder Developer Edition interface

Put the extracted folder in Portal's "apps" directory on the server

Added an application in Portal through the "My Content" page

Put the app's URL under Data Source in Web Mapping Application Settings

Registered the app and put the App ID in the the app's config.json file

Set the redirect URIs to http: //<server name>:[port] and https: //<server name>:[port]


The app seems to load in Portal. It prompts for login to view the map, and if I change the data source URL at all it returns an error ("Page not found"). The problem I'm having is that when the "Request for Permission" window pops up and I click "Approve", the window goes blank and just hangs there.


I feel like it might be an authentication/configuration issue, but maybe I'm way off track. Any input would be much appreciated!