AnsweredAssumed Answered

Geoprocessing task not using provided file paths

Question asked by devonc1301 on Jan 2, 2018
Latest reply on Jan 4, 2018 by devonc1301

I have a geoprocessing task on ArcGIS Server 10.1 that uses arcpy's Select By Location on a number of layers and writes a SQL file based on the results. For each iteration of the selection I'm passing a path to where the layer is located yet I'm getting this error:

ERROR 000732: Input Features: Dataset C:\arcgisserver\directories\arcgissystem\arcgisinput\RegQueryBuilder2\RegQueryBuilder.GPServer\extracted\v101\tigerdata\Zips\esriZipsLayer_NAD83.shp does not exist or is not supported

I'm wondering why the task is looking in this folder when I have hardcoded file paths (not env.workspace) in the script. I tried setting the workspace and scratch workspace environments in the initial execution of the script tool which was used for creating the geoprocessing package but I got the same error.


PS: I had worked around this error by copying the layers to that folder location but since the layers are very large it won't work for production.