aparker1969

Please help with errors - Failed to start Core Services

Discussion created by aparker1969 on Nov 5, 2010
Latest reply on Aug 8, 2012 by espipa
Installed ArcGIS Server 10 Java on RHEL5 server.  Everything went fine.  Even built a few test maps.  Other projects took priority and I shut down the server for a few weeks.  When I booted back up the test server and tried to log into the Manager.  I received the error "Incorrect login information". 

I ran the diagnostic tool (<ArcGIS Server Installation Directory>/scripts/Server_diag_tool) which provided the following.

[INDENT] DG027 - check process: mwrpcss                                        [FAILED] *
DG027 - check process: regss                                          [FAILED] *
DG027 - check process: watchdog                                       [FAILED] *
DG027 - check process: remotesa                                       [PASSED]
DG027 - check process: ns-slapd                                       [PASSED]
DG027 - check process: arcsom.exe                                     [FAILED] *
DG027 - check process: java -jar arcgis_manager                       [PASSED]
DG027 - check process: managerappserver                               [PASSED]
DG027 - check process: service/derby/lib/derby.jar                    [PASSED]
DG027 - check process: Xvfb                                           [PASSED]
DG001 - check /etc/hosts: has entry for localhost                     [PASSED]
DG002 - check /etc/hosts: localhost = 127.0.0.1                       [PASSED]
DG003 - check /etc/hosts: has entry for saturn.nmt.edu                [PASSED]
DG004 - check /etc/hosts: saturn.nmt.edu != 127.0.0.1                 [PASSED]
DG043 - check /etc/hosts: IP address 129.138.10.6 is correct          [PASSED]
DG005 - check /etc/passwd: user agsadmin                              [PASSED]
DG005 - check /etc/passwd: user agsuser                               [PASSED]
DG006 - check /opt/arcgis/server10.0/: owner                          [PASSED]
DG007 - check /opt/arcgis/server10.0/: permissions                    [PASSED]
DG008 - check /opt/arcgis/server10.0/: has space                      [PASSED]
DG009 - check /opt/arcgis/server10.0/servercore/tmp/mw: exists        [PASSED]
DG010 - check /opt/arcgis/server10.0/servercore/tmp/mw: is writable   [PASSED]
DG011 - check /opt/arcgis/server10.0/servercore/tmp/mw: has space     [PASSED]
DG012 - check /etc/remotesa: owner                                    [PASSED]
DG013 - check /etc/remotesa: permissions                              [PASSED]
DG012 - check /etc/remotesa/remotesa.config: owner                    [PASSED]
DG013 - check /etc/remotesa/remotesa.config: permissions              [PASSED]
DG016 - check Registry for ESRI\ArcServer                             [FAILED] *
DG016 - check Registry for ESRI\ArcServer                             [FAILED] *
DG018 - check Core Services: is running                               [FAILED] *
DG019 - check Core Services: RPC Port                                 [PASSED]
DG020 - check Core Services: Enterprise mode                          [PASSED]
DG021 - check Core Services: Administrator                            [PASSED]
DG022 - check Security: Type                                          [FAILED] *
DG023 - check Security: Port                                          [FAILED] *
DG024 - check Security: Domain                                        [FAILED] *
DG025 - check Security: DomainServer                                  [FAILED] *
DG026 - check Security: DomainServerSecondary                         [FAILED] *
DG048 - Solaris only - check the value of the max-descriptors         [N/A]
DG028 - check LDAP server: is listening                               [PASSED]
DG049 - check if saturn.nmt.edu is a valid SOM machine                [PASSED]
DG044 - check locale: Server locale matches environment locale        [FAILED] *
DG039 - check LDAP server: password storage scheme                    [PASSED]
DG040 - check LDAP server: password validity                          [PASSED]
DG029 - check permissions: arcsom.exe                                 [FAILED] *
DG030 - check permissions: arcsom.init                                [PASSED]
DG031 - check permissions: arcsoc.exe                                 [FAILED] *
DG032 - check permissions: arcsoc.init                                [PASSED]
DG033 - check User Mappings                                           [PASSED]
DG034 - check User Mappings permissions                               [PASSED]
DG041 - check if server configuration file(Server.dat) exists         [PASSED]
DG042 - check if security store config file(security.xml) exists      [PASSED]
DG015 - check /opt/arcgis/server10.0/server/serverdir/arcgiscache     [PASSED]
DG015 - check /opt/arcgis/server10.0/server/serverdir/arcgisindex     [PASSED]
DG015 - check /opt/arcgis/server10.0/server/serverdir/arcgisjobs      [PASSED]
DG045 - check if /opt/arcgis/server10.0/server/serverdir/arcgisjobs exceeds 30 characters[WARNING] !
DG015 - check /opt/arcgis/server10.0/server/serverdir/arcgisoutput    [PASSED]
DG036 - check SOC host saturn.nmt.edu: is reachable                   [PASSED]
DG037 - check SOC host saturn.nmt.edu: is running                     [FAILED] *
DG038 - check if port 8621 is listening                               [PASSED]
DG046 - Solaris version must be more recent than Solaris 10 8/07 update 5[N/A]
DG047 - Solaris must have Xvfb installed                              [N/A]

saturn.nmt.edu : ( 16 Failures, 1 Warnings, 3 N/A )

--1 of 1 machine(s)--

For more information about the diagnostics, please refer to ArcGIS Server web-based help:
http://links.esri.com/Performing_diagnostics_on_Linux_Solaris
or use the ArcGIS Server Manager Help
[/INDENT]

So I ran ServerConfig that gave me the following:
[INDENT]Beginning Task: Initializing..
   ERROR: Enterprise Core Services failed to start.
   Please check summary log file /opt/arcgis/server10.0/.Setup/configuration.log.  Detailed log files can be found at /opt/arcgis/server10.0/logs/Setup/configuration_logs.

Configuration did not complete successfully!!!
[/INDENT]

The output from the configuration.log is:[INDENT]
    Performing Initialization checks
    Performing Initialization checks
    Script owner check passed
    Script owner check passed
    Starting Enterprise Core Services..
    Starting Enterprise Core Services..
   ERROR: Enterprise Core Services failed to start.
[/INDENT]

The output from init.log is:
[INDENT]Failed to start Core Services: No permissions.[/INDENT]

And this is where I am stuck.  What is the next process?  Reinstall ArcServer?  Or is there a fix for this?  I want to try to fix this so I will know what to do if it happens again.

Thanks
~andrew

Outcomes