Symbology stored in web map JSON ONLY if symbology is configured in web map

Idea created by mrosenberg57 on Jun 29, 2018
    New
    Score20
    • mrosenberg57
    • thanos_cp78

    I republished a map service to update the symbology and it did not update int he web map. I found this article https://support.esri.com/en/technical-article/000014102 that suggests I remove the layers and re-add them. However, I never changed the symbology configuration to begin with. This workaround is unacceptable since I would be re-doing ALL of my work to configure the web map.

     

    I set the configuration of the pop-ups and I set custom labels (since the ones I created prior to publishing my AGS service did not appear on the web map... They were custom expressions and included a "newline" which is also unsupported in Arcade). When I created the labels, AGOL automatically stored symbology information in the web map JSON (I found this out through ago-assistant). Thus, AGOL thinks I applied custom symbology to the layers when I did not. So when I republish the map service, the symbology does not update (see article above). This is causing an issue since I have to redo all this configuration every time I want to update the symbology of the map service and have that show through my web map. I would like to log an enhancement request to only store symbology information in the JSON if I actually update the symbology through the tools in AGOL (not when I add labels). At the very least update the article above...