MSingleton-esristaff

Release of the Mid-Year 2015 Update to the Deprecated Features for ArcGIS

Blog Post created by MSingleton-esristaff Employee on Aug 21, 2015
This blog post provides updated information regarding deprecated features of ArcGIS 10.3.1 and the upcoming ArcGIS 10.4 release. ArcGIS 10.3.1 was released in May 2015.Note: Along with product updates, the name of this document has also been updated to reflect the content.

Here are some of the major changes in the update for ArcGIS 10.3.1 and the upcoming ArcGIS 10.4 release:

  • At 10.4, ArcObjects .NET will ship with the .NET Framework 4.5 as the default. All developers using ArcObjects .NET are encouraged to begin the transition from existing .NET-based extensions to the .NET Framework 4.5 in anticipation of this change.
  • Portal for ArcGIS 10.3.1 will be the last release to support Internet Explorer 7 and 8.
  • Beginning with the December 2015 update, ArcGIS Online configurable application templates and the map viewer will no longer support Internet Explorer 7 and 8.
  • ArcGIS 10.4.x will be the last series of releases to support Red Hat Enterprise Linux 5.x.
  • ArcGIS 10.3.1 and ArcGIS Pro 1.1 will be the last releases to support the Oracle 10g R2 10.2.x series of releases.
  • ArcGIS 10.4 will be the last release to support the Oracle Spatial GeoRaster data type.
  • ArcGIS 10.3.1 will be the last release to support Microsoft SQL Server 2008 and 2008 R2.
  • ArcGIS 10.3.1 and ArcGIS Pro 1.1 will be the last releases to support the PostgreSQL 9.1.x series of releases.

For more information on our deprecation plans, please refer to the following PDF document, Deprecated Features for ArcGIS 10.3.1 and 10.4 Releases.
Megan S. - Online Support Resources

Outcomes