Pro SDK を使用した ArcGIS Pro の拡張②:環境構築

Document created by takahiro_kamiyaesrij-esridist Employee on Apr 27, 2018Last modified by masanobu_hiranoesrij-esridist on May 1, 2018
Version 15Show Document
  • View in full screen mode

 

はじめに

 

この記事は、「Pro SDK を使用した ArcGIS Pro の拡張」シリーズの第2弾です。

 

当シリーズでは、ArcGIS Pro SDK (以下、Pro SDK) を使用した ArcGIS Pro を拡張方法などをご紹介していきます。

前回は、Pro SDK とはどういった開発製品かということと、ArcGIS Pro でどのようなカスタマイズが可能なのかをご紹介しました。

 

今回は、開発環境の構築方法についてご紹介します。

 

開発環境の準備

 

Pro SDK を用いて ArcGIS Pro の拡張アドインを開発するには、一般的に統合開発環境として Microsoft Visual Studio (以下、Visual Studio) を使用します。そのため、Pro SDK がサポートするバージョンの Windows OS Microsoft Visual Studio が適切にセットアップされている必要があります。

Pro SDK 2.1 を使用する場合には、Microsoft .NET Framework 4.6.1 Developer Pack のインストールが必要です。

 

Pro SDK がサポートする最新の動作環境につきましては下記をご参照ください。

ArcGIS Pro SDK for .NET 動作環境

 

Pro SDK のインストール方法

 

Pro SDK のインストールには、次の2つの方法があります。

  • 旧バージョンのインストール:GitHub からインストーラーをダウンロードしてインストールする方法
  • 最新バージョン※  のインストール:Visual Studio [拡張機能と更新プログラム] からインストールする方法

※ Visual Studio では、インストールできるバージョンは最新のバージョンのみですので、旧バージョンのインストールを行う場合は、GitHub からインストーラーをダウンロードします。

※ 最新バージョンは、Pro SDK 2.1 ですが、国内ではサポート対象外です。サポートの開始は 2018 年 6 月上旬を予定しています。

 

 

旧バージョンのインストール

旧バージョンの "1.4" や "2.0" をインストールするには、GitHub からインストーラーファイルをダウンロードする必要があります。

ここでは、Pro SDK 2.0 のインストールについてご紹介します。

 

1.下記の URL から GitHub のサイトにアクセスして Pro SDK 2.0 を選択します。

https://github.com/Esri/arcgis-pro-sdk/releases

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2.「proapp-sdk-templates.vsix」と「proapp-sdk-utilities.visx」をダウンロードします。

3.ダウンロードした「proapp-sdk-templates.vsix」と「proapp-sdk-utilities.visx」のファイルをダブルクリックすると VSIX インストーラーが起動しますので、[インストール]をクリックしてインストールを行います。

 

4.Visual Studio に ArcGIS Pro SDK for .NET のテンプレートとユーティリティのインストールされていることを確認します。

   確認は、「最新バージョンのインストール手順の 8 」と同じ方法で確認します。

 

 

最新バージョンのインストール

Visual Studio (バージョン 2017) [拡張機能と更新プログラム] を使用した最新バージョンのインストール方法をご紹介します。

 

1.Visual Studio を起動します。

2.Visual Studio [ツール] メニューから [拡張機能と更新プログラム] を選択します。

3[オンライン] 項目の [Visual Studio Marketplace] を選択します。

 

4.右上の検索ボックスに 「ArcGIS Pro SDK」と入力します。検索結果として「ArcGIS Pro SDK for .NET」と「ArcGIS Pro SDK for .NETUtilities)」が表示されます。

 

5.ArcGIS Pro SDK for .NET」 と 「ArcGIS Pro SDK for .NET (Utilities) 」 をそれぞれ選択し、[ダウンロード] をクリックします。

6.インストール内容を Visual Studio に反映させるため、ダイアログの下部に表示されている [閉じる] をクリックして、一度 Visual Studio を終了します。

 

7.[VSIX インストーラー] ダイアログが表示されます。 [変更] をクリックして、ArcGIS Pro SDK for .NETをインストールします。

 

8.Visual Studio に ArcGIS Pro SDK for .NET のテンプレートとユーティリティがインストールされていることを確認します。

 再度、Visual Studio を起動して [ファイル] メニューから [新規作成] [プロジェクト] を選択します。Visual C#および Visual Basic 用の新しいプロジェクトテンプレートのリストに「ArcGIS Pro モジュール アドイン」、「ArcGIS Pro 構成管理」が表示されていれば、インストールは完了しています。

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Visual Studio の設定

 Visual Studio では、Pro SDK の自動更新がデフォルトでオンとなっています。

ArcGIS Pro ArcGIS Pro SDK のバージョンが異なると、アドインの使用時などにエラーが発生してしまいます。そのため、自動更新をオフにすることを推奨しています。

 

【自動更新変更についての関連リンク (米国 Esri GitHub 英語)

 

Visual Studio で、[ツール] メニュー → [オプション] [環境] [拡張機能と更新プログラム] から[拡張機能を自動的に更新する] のチェックを外し、[OK] をクリックすることで、自動更新をオフに設定することが可能です。

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

これで開発環境の構築は完了です。

次回は、Pro SDK で実装するための基本構成などについてご紹介していきます。

 

■関連リンク

Esri Web サイト:
ArcGIS Pro SDK

ArcGIS Pro SDK コンセプト(GitHub
ArcGIS Pro SDK サンプル集(GitHub
ArcGIS Pro API リファレンス

Attachments

    Outcomes