Skip navigation
All Places > GIS > Web GIS > ArcGIS Online > Blog > Author: Lapoutra

ArcGIS Online

1 Post authored by: Lapoutra

When polygons contain curves in your source feature class feeding your Portal Feature Layer (by reference), these polygons will not display. I came across this bug and could not figure out why certain polygons were not displaying in Portal. After trying many things, the ESRI analyst and I figured that feature classes that had been dropping were making it through when when we did a conversion to a shapefile prior to copying into the registered file geodatabase...

 

Then some more experimentation with geoprocessing tools trying to doctor the layer lead me to the simplify geometry tool (retaining critical points selected), which seemed to fix the original data.

 

Then looking at individual vertices, I noticed the simplify geometry was adding vertices in areas where we had missing polygons. This was because the bezier curves were being turned into small linear segments...

 

So in ArcGIS Enterprise 10.7.1, curves in data by reference will not display in feature layers. 

A bug has been filed:

#BUG-000125177 Portal 10.7.1 Map Viewer fails to draw polygons containing non-linear segments in a feature layer

 

A last check with the data reviewer "Check Non-Linear Segments" confirmed that the issue was caused by curves (see attachments). In our case, one of our feature layer was missing ~28k polygons !!

 

So the work-around at this point is:

Run a simplify geometry with the adequate tolerance (~0.01 feet for use) on your feature class to turn your curves into linear segments.

 

It is likely this issue also impacts polylines.

 

Hope this can help other people!

 

Adrien