BRollison-esristaff

Discontinuing Support for IE11 & Edge Legacy in Layout Editor

Blog Post created by BRollison-esristaff Employee on Jun 3, 2020

Early next week, ArcGIS Hub is discontinuing support for Internet Explorer 11 and Edge Legacy browsers in the layout editor for all Hub Sites and Hub Pages.  To the best of our knowledge, an extremely small percentage of you will be impacted by this change — if you fit into this cohort, then continue reading below.

 

WHAT DOES THIS MEAN FOR YOU?

If you are using Internet Explorer 11 or Edge Legacy, then upon entry into the layout editor for either a Hub Site or Hub Page you’ll be met with an “Unsupported Browsers” splash screen.  This screen will prevent you from previewing the Hub Site or Hub Page and accessing most of the layout editor controls you may be familiar with.  You’ll still be able to adjust your Hub Site’s settings, share, delete, and save your Hub Site or Hub Page; however, controls such as header/footer configuration, site theming, and all layout functionality will be inaccessible.

 

DOES THIS IMPACT VIEWING MY SITE?

Internet Explorer 11 and Edge Legacy users will still be able to view and explore your Hub Site as usual — to repeat, there will be no material impact to viewing Hub Sites and Hub Pages outside the layout editor.

 

IS THIS THE ONLY PLACE I CAN’T USE IE11 OR EDGE LEGACY WITHIN HUB?

Yes, only the layout editor will have Internet Explorer 11 and Edge Legacy supported discontinued at this time.

 

HOW DOES THIS IMPACT ENTERPRISE SITES?

Customers upgrading to Enterprise 10.8.1 will experience no changes in their use of Internet Explorer 11 or Edge Legacy within the layout editor on Enterprise Sites — there will be no splash screen.

 

WHAT IS THE PLAN FOR IE11 AND EDGE LEGACY GOING FORWARD?

If you’ve browsed ArcGIS documentation recently (ArcGIS OnlineWeb AppBuilder, Survey123, etc.) you’ve likely seen warnings that support for Internet Explorer 11 and/or Edge Legacy will be discontinued at a future release.  Additionally, some ArcGIS applications/functionality already don’t support the browsers at all or offer limited availability (JSAPI 4.x, StoryMaps, Urban, etc.).

 

In the coming months Esri will be communicating a forward-looking plan regarding ongoing support for Internet Explorer 11 and Edge Legacy, please stay tuned to your regular information channels for updates.

 

WHERE CAN I DOWNLOAD A “MODERN BROWSER”?

You are likely already use a “modern browser” in your daily life, recommended browsers are the following…

 

HOW DO I KNOW IF I’M USING EDGE LEGACY?

Microsoft has a simple set of instructions; if you see a version number format such as 80.0.000.00 in your browser settings, then you are using the new Microsoft Edge (it’s pretty great actually, even on macOS).  Current Edge Legacy users can learn more about upgrading here.

 

Hope this answers any questions you might have 

Outcomes