JLenhardt-esristaff

Mosaic Datasets created or edited with Pro 2.3 require ArcGIS 10.7

Blog Post created by JLenhardt-esristaff Employee on Mar 13, 2019

If you create or modify a mosaic dataset in Pro 2.3, it can only be read and modified by ArcGIS Pro 2.3 and ArcMap 10.7 and served with ArcGIS Image Server 10.7 or newer. If you intend to publish your mosaic dataset to an image server prior to 10.7, do not create or edit it using Pro 2.3.

 

Note that for ArcGIS Pro 2.3, significant changes were made to the internal structure of the mosaic dataset so once modified using Pro 2.3, the updated mosaic dataset cannot be read on older versions.

 

In general, mosaic datasets created with older versions of ArcGIS can be read and handled with newer versions of ArcGIS. However, a mosaic dataset created with a newer version of ArcGIS may not be backwards compatible with older versions.

 

See the table below for mosaic dataset compatibility:

 

 Mosaic Dataset compatibility between versions

 

Users utilizing a mosaic dataset created with a new version that does not use any new features in that version, have been able to read a mosaic dataset with an older version.  However, this may cause incompatibility issues.

Outcomes