
STYLING 

1. Can you click on features to see all the attributes you can edit at any zoom level? 

If you click on a feature it will show all the attributes you can edit. If there are scale range based attributes, you will 

be able to edit those too. The scale based attributes are separated into categories called ‘stops’. 

2. If you change styling settings, does it overwrite the quick edits you have already made? 

Yes. Once you go beyond the Quick Editor pane those changes you make will take hold.  

3. Is scale based transparency supported? 

Yes. It is called opacity, but it is most definitely supported. Use the gear icon to select ‘Set Value by Zoom Level’ 

option. Then you can set scale based settings called ‘stops’.  

4. Can we use our own custom aerial imagery in conjunction with ESRI labels? 

Yes. You can use a Reference layer or create your own stylized label layer and put that on top of your imagery in a 

web map. (See enhancements #1) 

5. Can you add your own layers/data into the basemap? 

Not directly. However, you could combine your own data and basemap data together as separate layers in a web 

map. (See enhancements #2) 

6. Does the quick editor color change output different colors on different features? For example, if changing 

the water to a certain hex value do some water features get different shades of blue? 

When a quick editor color is changed it will adjust most of the impacted features to that color. The exceptions are 

things liking road casings and bathymetry. Sometimes that color is ramped so that the casing of a road is 

maintained or the essence of the bathymetry is kept.  

7. How does the quick editor adjust road widths? 

You can either select to widen them or narrow them (and this will be done across all scales). It will keep the relative 

road hierarchy intact and road casing intact.  

8. How do you turn off labels based on feature type? 

You can go to the specific feature and switch the visible toggle to off.  

9. Why do some layers have limited zoom ranges (i.e. Land Use\ Park or Farming) 

To make the Vector Tiles as small and efficient as possible some features are only generated out to certain scales. 

10. Are there any tutorials available to walk through the process of making a custom basemap? 

There are various blogs and story maps that walk through the process. The blogs with the following tag will collect 

most of those: #vector basemaps. 

The Basics: https://arcg.is/19KayS  

Colors: https://arcg.is/0Lj5zv  

Lines: https://arcg.is/1f0T18  

Labels: https://arcg.is/1eD5ae  

Fonts and Sprites: https://arcg.is/1PDSCS 

 

https://www.esri.com/arcgis-blog/?s=#%23vector+basemaps
https://arcg.is/19KayS
https://arcg.is/0Lj5zv
https://arcg.is/1f0T18
https://arcg.is/1eD5ae
https://arcg.is/1PDSCS


11. How do you lock the extent if you have styled the map for a specific place? 

You cannot lock the extent in the editor but you could in app you are making it for (depending on which app) 

12. How does the reset style button differ from the undo button? 

The reset will revert back to the original style while the undo will undo the last change.  

13. What are the terms of use (copyright) for custom basemaps if we create them for a specific business or 

website? 

The standard Esri copyrights exist. The Terms of Use information: View Summary | View Terms of Use The sources 

copyright: Esri, HERE, Garmin, FAO, NOAA, USGS, © OpenStreetMap contributors, and the GIS User Community 

 

14. Can you style by scale? 

Yes. Use the Set Value by Zoom level functionality found in the gear icon for each feature’s attributes and then add 

stops which will allow you to design based on scale. 

15. Can you center the map somewhere else? 

You are free to move all four map windows to whatever scale and location you want. If you save the web map 

centered on a location/scale, that location will be preserved when you open the web map again. 

16. How are scale dependencies determined? 

Features are ‘cooked’ into the tiles based on a predetermined scale. For the basemaps this is determined by Esri. 

For your content, it would be determined by your settings in Pro. With the editor, you have the ability to turn off 

features if they were cooked into a scale but you can never turn them on beyond the scales they were cooked.  

17. Why are those sub windows based on the scales that they are? 

They show the map at various scales where there is often a transition in the way features are symbolized. 

18. How does one change the code for disputed names? 

You will need to make a copy of the tile layer and save to your own account. Download the root.json file and make 

the edits to the filter values based on the available names listed in the Esri Vector Basemap Reference Document 

(v2) pages 29-30. This blog also discusses filter editing in the JSON. Once edited (and root.json file is validated 

through http://jsonlint.com) you can update your item’s style (root.json file). 

19. Can I share my custom style to Enterprise (Portal)? 

If you have a custom style in an ArcGIS Online account (not Enterprise) you can download that style’s root.json to 

port over to Enterprise. Save a copy of the Esri vector basemap style you started with so the sprites are the same in 

your online account. Update the style in Enterprise using your online custom root.json. 

20. When adjusting the width of roads via the quick editor do the buildings and other items adjust too? 

The option to adjust road widths in the quick editor will only affect the roads.  

21. Can you use a predefined color set or do you have to manual enter the colors in the quick editor? 

You can totally use a predefined color set but at this point you do have to manually enter the colors. However, due 

to the way the categories are grouped in the quick editor the amount of manual cutting and pasting is very 

minimal. 

http://links.esri.com/tou_summary
http://links.esri.com/agol_tou
http://esri.maps.arcgis.com/home/item.html?id=c908722b0841404ba6a87d6221f201e4
http://esri.maps.arcgis.com/home/item.html?id=c908722b0841404ba6a87d6221f201e4
https://www.esri.com/arcgis-blog/products/arcgis-living-atlas/mapping/customize-esri-vector-basemap-boundaries-and-labels/?rmedium=redirect&rsource=/esri/arcgis/2015/11/23/customize-esri-vector-basemap-boundaries-and-labels
http://jsonlint.com/


22. Are the road icons vector? 

The icons are PNG and are referenced in the vector map via a sprite sheet. There are two sprite sheets:  one PNG 

file for high resolution devices and one PNG file for typical resolution devices. 

23. Can you delete labels? 

You cannot delete anything with the Vector Editor. Instead you can turn features on and off getting the same 

effect. 

24. Will the amount of styling have any effect on the load time for the basemap? 

In general, the expectations are it will not. Certain styling may increase load time for the vector basemaps. This 

includes adding duplicated layers of features or heavy use of patterned sprites across large areas of the map. 

Certain styling may decrease load time if you make many features not visible.  

25. Is it possible to take the style from an ESRI basemap and apply it to a custom vector layer? Is it possible 

through JSON? 

Not directly, but can be done and would require manual application of the styles from our features to a custom 

vector layer. The attributes being styled through the JSON most likely would not be reflected in your custom vector 

layer, but you could apply the specifications from one to the other. 

26. How do I load my own vector basemap into the editor? 

If you are signed in with your online account, the ‘My Styles’ tab of the editor will display your own basemap. 

 

JSON 

1. How can I see the JSON file behind the Editor? 

You can do this via the content item which is created. Log in to your Online account and go to My Content, select 

the item you want to review. On the map item page there will be a view style button. You can also download the 

root.json file.  

2. Can you use Google fonts in the JSON file? 

No. We do use Google fonts but in order to be used in the vector format they are encoded as PBF files. You cannot 

reference Google fonts directly in the JSON. The list of fonts we currently include in our Esri vector basemaps can be 

found in the Reference Document (v2) on page 31. 

 

CUSTOM VECTOR MAPS 

1. Can I use my own scales to create vector basemaps e.g. 1:250, 1:500 etc.? 

Yes. If you are creating your own custom vector map in ArcGIS Pro you can use whatever tiling scheme you want. 

However, if you want to combine that with an Esri Basemap it will not be compatible. 

2. Does the Vector Editor work with VTPK’s we create and upload? 

Yes. The only functionality not available will be the quick editor as that is locked into an Esri basemap experience. 

But everything else will be fully functional. 

http://esri.maps.arcgis.com/home/item.html?id=c908722b0841404ba6a87d6221f201e4


3. Are there plans to allow the uploading of a shapefile to the vector editor? 

No.  

4. Are there known max scale limitations for creating vector tile layers? 

The min and max cached scales you choose must be scales defined within the tiling scheme. 

5. Are you able to edit your Organization’s Vector Basemaps or only Esri’s? 

You definitely can use the Vector Editor to edit your own vector basemaps. 

 

ENVIRONMENT 

1. Can I use a vector map in ArcGIS desktop (what platforms are supported)? 

ArcGIS desktop is not supported. One should use ArcGIS Pro as the desktop solution for vector maps. More 

information on Vector tiles can be found here.  

2. Is it possible to have the basemap stored locally/exported to a PMF file 

No, see this support article. PMF are only created through the Publisher extension of ArcGIS for Desktop, not Pro. 

Desktop does not support vector tiles, Pro does. 

3. Is this Editor available for ArcGIS Enterprise (Portal)? 

Currently, no it is not. 

4. Are custom Vector maps compatible with the offline Collector workflow? 

The next generation of Collector is planning to be compatible with vector maps. 

5. How do you use these custom maps in Business Analyst? 

In Business Analyst (Online) > Maps > Add Data > Web Maps and Layers > find your custom vector basemap in your 

account or add any of the Esri Vector Basemaps (including our creative styles) from the Living Atlas > Basemaps 

category. 

6. What browser works best? 

Vector tile layers have the best performance on machines with newer hardware, and they can be displayed in most 

current versions of desktop browsers, including Chrome, Firefox, Safari, Internet Explorer 11, and Edge. You can add 

vector tile layers as operational layers or basemaps to Map Viewer or Scene Viewer. 

7. Are we able to use our custom basemaps for applications that are already built? 

Yes, if the client supports vector basemaps. You will need to replace your existing map with the new custom vector 

basemap. 

 

ONLINE 

1. Is there any credit consumption using the vector editor? 

No. The only credit consumption would be the standard storage of any item created. 

https://doc.arcgis.com/en/arcgis-online/reference/tile-layers.htm#ESRI_SECTION1_8F68399EB47B48FF9EF46719FCC96978
mailto:https://support.esri.com/en/technical-article/000012485
https://www.esri.com/arcgis-blog/products/apps/field-mobility/collector-for-arcgis-releasing-the-aurora-project/


2. Can a custom basemap be set as the default for an AGOL organization? 

Yes, you need to create a group and share the custom basemap (web map) to that group. Then the administrator 

can make changes on the Settings > Map section of the Organization in ArcGIS.com. Set the Basemap Gallery to the 

group. Set the Default basemap from within this group.  

3. Does the Vector Editor require an Online Account? 

Yes, if you wish to save your custom style. 

4. Is this in BETA? 

Yes, currently the Vector Editor is in BETA 

5. How do I access the generated JSON after saving? 

Log in to your ArcGIS.com account and go to the item page of this saved custom style. There will be buttons to View 

Style and Download Style (downloads root.json). 

6. What type of online account do you need?  

Is student or personal okay or do you need an organizational account? 

Any of the accounts (Student, Personal or Organization) are okay; however, there are different terms of use based 

on account type. For example, items in a personal account are not for commercial use. 

7. How do you access the customized basemap through online? 

To access the Esri Vector Basemap Customized maps, there are three main ways: through the Vector Basemaps 

Group, through the Living Atlas > Basemaps > Vector Tiles, or through the Map Viewer > Add > Browse Living Atlas 

> Basemaps > Vector Tiles. To access your own customized basemap through online, if public item you can add 

them through the Map Viewer > Add > Search for Layer > My Content. If private item, you will need to log in first. 

8. How do you access the custom style in Online if it is saved privately? 

If you own the item, log in to your online account. You can access a custom style that you saved through the My 

Content tab. Also, in the ArcGIS.com Map Viewer > Add > Search for Layer > My Content for the item name of your 

saved style (tile layer). For others to be able to find the style or for you to find others’ privately saved styles, the 

styles will need to be shared (either within your organization or publicly). 

9. How do you access the saved style via online? 

The styles saved from the Vector Style Editor will appear in the My Content section of the online account that you 

logged in to the Editor with. They can be accessed through the ArcGIS.com Map Viewer > Add a layer > browse your 

content for the item name of your saved style (tile layer). 

10. Can the customized basemaps be taken offline? 

Yes, currently through this developers story. There are plans to create the vector basemaps for offline use out of 

Pro. The next generation of Collector is expected to consume vector tiles. Please be aware of the terms of use for 

vector basemaps. 

11. How do you add a vector map to portal? 

Adding a vector map to Enterprise is similar to ArcGIS Online. Starting with Enterprise 10.5.1, Esri Vector Basemaps 

are accessible through the Living Atlas for Portal. Maps are found under the Gallery tab > Basemaps > Esri 

http://www.arcgis.com/home/group.html?id=30de8da907d240a0bccd5ad3ff25ef4a
http://www.arcgis.com/home/group.html?id=30de8da907d240a0bccd5ad3ff25ef4a
https://livingatlas.arcgis.com/en/browse/#d=2&cont=esriOnly&categories=Basemaps:00100
https://www.arcgis.com/home/webmap/viewer.html?useExisting=1
https://www.arcgis.com/home/webmap/viewer.html?useExisting=1
https://developers.arcgis.com/java/latest/sample-code/export-vector-tiles.htm
https://www.esri.com/arcgis-blog/products/arcgis-enterprise/uncategorized/take-advantage-of-living-atlas-content-in-your-arcgis-enterprise/


Basemaps. In newer versions of Enterprise, there is also a Living Atlas tab under Content. In the Map Viewer > Add 

> Browse Living Atlas > Basemaps category > Vector Tiles sub-category. 

12. Can I tag a custom style as authoritative so that everyone knows in my org that it meets our org 

standards? 

If you are the administrator you will have the Mark as Authoritative button on the Settings tab for the custom style 

item. See this blog for more information on authoritative items. 

13. Where are vector maps available? 

Esri Vector Basemaps are available in ArcGIS.com, Pro, and some mobile applications like Explorer for ArcGIS. Find 

them easily through the ArcGIS Living Atlas of the World, Basemap category, Vector sub category. 

14. How do you incorporate a vector basemap into the web app builder? Do you just reference the portal or 

AGOL url? 

The app created by Web AppBuilder for ArcGIS is based on a web map or web scene from ArcGIS Online or Portal 

for ArcGIS. Reference the Web AppBuilder doc for more information. 

15. How do you combine the refence and map layers? 

In the map viewer, when you modify the map, add the layer(s) you wish to include in your map. For Reference 

layers, you can move them to the basemap and then set that layer as a reference layer. With this configuration, any 

operational data you add will appear “sandwiched” between your base layer and the reference layer. You can also 

add the layer(s) in Pro to build the map you want. 

16. How would I go about publishing my basemap style for use on a website? 

One way is the save your basemap style as a web map, then share the map. This will provide a URL to access the 

map. This URL can be included on your website. 

 

ArcGIS Pro 

1. How do you load a saved vector style into ArcGIS Pro? 

When you are logged into your portal and have it set as active, you can access the Catalog pane and add the saved 

vector style (tile layer) from your portal. 

2. When exporting a custom style from pro the labels are not at a high resolution. Can this be fixed? 

Yes. You need to have the fonts installed on your machine to get them to export at a high resolution. If you are 

unsure about the font, go to the Vector Editor to find it. For the most part, these fonts are open source and can be 

found and downloaded from Google fonts. The list of fonts we currently include in our Esri vector basemaps can be 

found in the Reference Document (v2) on page 31. 

3. Can you take an ArcMap document used to create raster tiles and move it to ArcGIS Pro to create vector 

tiles? 

Yes, but results may vary depending on the functions applied to the styles in ArcMap (e.g. Maplex label engine 

setting). Pro has some additional settings useful for vector tile creation, such as scale based display of features. 

There may be some tweaking of the file once you move it to Pro. 

4. Can you export vector maps as high resolution or vector files into graphic packages like Illustrator? 

https://www.esri.com/arcgis-blog/products/arcgis-online/announcements/whats-new-public-authoritative-content/
https://doc.arcgis.com/en/web-appbuilder/create-apps/map-tab.htm
http://esri.maps.arcgis.com/home/item.html?id=c908722b0841404ba6a87d6221f201e4


Yes, on the Share tab, Export map offers several different file formats. Please follow the terms of use of the 

basemap. 

5. Can you shed some light on exporting? 

 

See question above for exporting vector maps from Pro. Exporting maps for offline use, the vector basemaps have 

primarily a Developers story. User interface for taking the vector basemaps offline from Pro and for use in Collector 

is planned. Please follow the terms of use of the basemap. 

 

6. How do you change the coordinate system? 

In Pro > Contents > Map > Properties > Coordinate System 

 

JAVASCRIPT 

1. What is the best way to publish these styled maps and load into an ARCGIS JavaScript applications? 

Refer to ArcGIS for Developers page for details. This is another link on the developers site for the JavaScript API. 

 

CONTENT 

1. How is Community content updated? 

Through the Community Maps Program, contributors provide updates on a cycle they set (some of our participants 

update monthly, quarterly, semi-annually, or annually. Data is integrated into our central database and included as 

part of our core tile set. These updates appear online about every three weeks. See the CMP page on what is 

accepted. 

2. Do you have a method in place to verify the source of the feedback on the basemaps and can I be verified 

as an expert in my geographic region? 

The verification depends on the source of the data being mapped. We use a mixture of commercial, community and 

open sourced data depending on the area. Suggestion if you are submitting feedback is to include reference 

information (URLs) showing the correct information. If you have data for a specific area, consider becoming a data 

steward through the Community Maps Program. 

3. Is there a way to customize a basemap to use your own aerial photography? 

As long as your aerial imagery and the basemap (reference layer) are in the scale coordinate system, you can use 

your aerial imagery as the base layer and then either an Esri Vector Basemap reference layer or your own 

customized reference layer. The Esri Vector Basemaps are available in Web Mercator and WGS84 GCS. 

4. How do you add a specific basemap like 1997 imagery to the basemap gallery? 

As an administrator, create a web map from this specific imagery layer, share it to a group. The group can be set 

where the contents will be used for the basemap gallery. ArcGIS.com organization > Settings > Map > Basemap 

Gallery. Any web maps added to this group will appear in the gallery. 

 

ENHANCEMENT  

mailto:https://developers.arcgis.com/labs/javascript/display-a-styled-vector-basemap/
mailto:https://developers.arcgis.com/javascript/3/jsapi/vectortilelayer-amd.html
https://livingatlas.arcgis.com/en/participate/#v=community&subTab=what-to-contribute
https://livingatlas.arcgis.com/en/participate/#v=community&subTab=what-to-contribute
http://www.arcgis.com/home/group.html?id=30de8da907d240a0bccd5ad3ff25ef4a
http://www.arcgis.com/home/group.html?id=4c790318395940c18a16e8acd721de25#overview


Enhancement requests to the Vector Editor (Beta) are best added in the Style Editor space on GeoNet. 

Enhancement requests to the Esri Vector Basemaps are best added in the Living Atlas space on GeoNet. 

Content issues of the Esri Vector Basemaps are best reported on the Vector Basemap Feedback map. 

1. Can we use our own custom aerial imagery as reference in the Vector Editor? 

Not as of yet. It is an item in the backlog.  

2. Can you add your own layers into a basemap? 

Currently you would need to use separate layers. A layer for the Esri Vector Basemap, plus one or more of your own 

layers. Layers need to be in the same coordinate system.  

3. Can one mark or limit features in a basemap to one state or filter to show UTAH as green and the rest of 

the US as grey, for example)? 

Not as of yet. It is an item in the backlog.  

4. Can you upload custom fonts? 

Not as of yet. It is an item in the backlog.  

5. Can we apply styles from a basemap to our own data? 

Not yet. It is an item in the backlog.  

6. Are legends supported? 

No. 

7. Can you add a reference layer to a base layer in the Vector Editor? 

Not yet. It is an item in the backlog.  

8. Can you filter the labels via the Vector Editor? 

Not yet.  

9. Are there plans to implement these capabilities natively to ArcGIS? 

Plans to implement into ArcGIS Online have been discussed, but no timetable has been set.  

10. Can I use a raster as a pattern fill in a background? 

Yes, if that pattern is currently part of the map’s sprite set. In a future update, will you be able to upload your own 

raster fill or icon. 

 

 

https://community.esri.com/community/arcgis-vector-tile-style-editor/pages/overview
https://community.esri.com/community/arcgis-living-atlas-of-the-world
https://www.arcgis.com/home/webmap/viewer.html?webmap=28450cb78b324aaeaadb751e92d16ae0

