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Overview 

The ArcGIS GeoEvent Extension for Server is an extension for ArcGIS for Server.  The GeoEvent Extension 

can be used to incorporate real-time event data into the ArcGIS system.  The GeoEvent Extension 

satisfies a growing demand across multiple industries to incorporate real-time streaming data into 

everyday GIS applications, workflows, and analyses. 

This document illustrates the process of integrating data provided by the PreCise MRM GeoEvent 

Connector into an ArcGIS Feature Class which resides on an Enterprise DBMS (MS SQL Server is used in 

this example).  The process may need to be altered to accommodate your specific environment. 
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Prerequisites 

 ESRI ArcGIS Server 10.3 (or later) 

o More information available at http://server.arcgis.com/en/server/ 

 ESRI ArcGIS Server 10.3 (or later) GeoEvent Processor extension (this component is available 

from ESRI). 

o http://server.arcgis.com/en/geoevent-extension/ 

 ESRI ArcGIS Desktop 10.3 (or later), including the following: 

o ArcCatalog 10.3 

o ArcMap 10.3 

 PreCise MRM GeoEvent Connector files: 

o PreCiseInboundTransport-10.3.0.jar 

o PreCiseInboundAdapter-10.3.0.jar 

 Supported DBMS for ESRI ArcGIS Server 10.3 (MS SQL Server, PostgreSQL, Oracle, etc) 

 PreCise MRM feature class definition 

o PreciseAssets_10_3_0.XML (XML Workspace Document Import) 

 Refer to the PreCise ArcGIS GeoEvent Connector 10.3.pdf  for specific instructions on installing 

the PreCise MRM GeoEvent Connector. 
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Creating the Feature Class 

In order to download PreCise MRM AVL data into your local ArcGIS Server, a DBMS geodatabase must 

be added to the ArcGIS Server configuration.  The feature class associated with the PreciseAsset schema 

can then be created on the geodatabase 

1. Register the geodatabase 

a. Open the ArcGIS Server Manager  

i. http://<ArcGIS Server IP>:6080/arcgis/manager 

b. Go to Site -> GIS Server-> Data Store 

c. Register your geodatabase, if not already registered 

d. More information regarding registering a database with ArcGIS Server is available at 

http://server.arcgis.com/en/server/latest/publish-services/windows/registering-your-data-

with-arcgis-server-using-manager.htm 

 
2. Create the feature class via Import 

a. Open ArcMap 

http://www.precisemrm.com/
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b. Expand the Catalog window 

c. Expand Database Connections in the Catalog Tree 

d. If your geodatabase is not already listed, double-click Add Database Connection 

i. Enter the geodatabase details for you environment. 

ii. More information regarding database connections is available at 

http://desktop.arcgis.com/en/desktop/latest/manage-data/gdbs-in-sql-

server/connect-sqlserver.htm 

e. Right-click the geodatabase in the Catalog Tree.  Select Import -> XML Workspace 

Document… 

f. In the Import XML Workspace Document window 

i. Select Schema Only 

ii. Specify the XML source document by browsing to the location of the 

PreciseAssets_10_3_0.XML file 

 
iii. Click Next > 

http://www.precisemrm.com/
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iv. Review the import summary and click Finish when ready to complete the import. 

 
g. The PreciseAssets feature class can be moved into a Feature Dataset if desired.  However, 

ensure that the PreciseAssets feature class and associated feature dataset utilize the WGS 

1984 (GCS_WGS_1984, WKID: 4326) Geographic Coordinate System. 

http://www.precisemrm.com/
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Sharing the Feature Class 

The feature class must be shared as a service in order for the GeoEvent Extension to interact with the 

feature class.   

1. Share the PreciseAssets feature class as a Service 

a. Open ArcMap 

b. In the ArcMap – Getting Started window, choose the Blank Map template. 

c. Expand the Catalog window 

i. The PreciseAssets feature class should be visible under Database Connections 

d. Drag and drop the PreciseAssets feature class from the Catalog window over to the Table Of 

Contents window (where the empty Layers is displayed) 

 
e. Right-click the PreciseAssets layer, select  Properties 

f. On the Symbology tab  

i. Select Categories -> Unique Values  

http://www.precisemrm.com/
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ii. Set the Value Field = AssetName (groups asset entries based on the Asset Name when 

viewed) 

 
iii. Click Apply 

g. Select File -> Save As 

i. Save the file as PreCiseAssets.mxd 
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h. Select File -> Share As -> Service 
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i. Select Publish a Service  

 
ii. click Next > 

iii. For Choose a connection, select your ArcGIS server 

http://www.precisemrm.com/
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iv. For Service name, enter a service name such as “PreCiseAssets “ 

 
v. Click Next > 
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vi. For Publish service to folder, select an existing folder or make a new folder 

 
vii. Click Continue 

i. The Service Editor window will then launch 

http://www.precisemrm.com/
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i. In Capabilities, check Mapping and Feature Access 
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ii. In Capabilities -> Feature Access, the default configuration will work 

 
iii. Select Analyze.  Check for any errors in ArcMap under the Prepare window 

http://www.precisemrm.com/
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iv. If there are no errors, select Publish 

 
2. Confirm the Service is shared 

a. Open the ArcGIS Server Manager  

i. http://<ArcGIS Server IP>:6080/arcgis/manager 

b. Go to Services -> Manage Services  

http://www.precisemrm.com/
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c. The PreCiseAssets service should now be visible in the site applicable site folder 
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Creating the PreCiseAssets Feature GeoEvent Definition 

A GeoEvent definition must be created for the PreCiseAssets feature class created in the last step.  This 

GeoEvent definition will allow for field mapping variations when converting incoming PreCise GeoEvent 

data (using a hierarchical structure) to the PreCiseAssets feature class which exists on your geodatabase 

(using a flat structure).  

1. Open ArcGIS GeoEvent Manager 

a.  https://<ArcGIS Server IP>:6143/geoevent/manager 

2. Import the GeoEvent Definition 

a. Go to Site -> GeoEvent -> GeoEvent Definitions 

b. Click Import GeoEvent Definitions 

c. Create the GeoEvent Definition with the following settings: 

i. Registered ArcGIS Server:  Select the registered ArcGIS connection created earlier 

ii. Folder:  Select the folder containing the shared PreCiseAssets service on your ArcGIS 

Server 

iii. Service:  Select the PreCiseAssets feature service created earlier 

iv. Layer:  Select the PreCiseAssets feature layer shared via the PreCiseAssets service 

v. Unique Identifier Field:  AssetID

 
d. Click Import 

http://www.precisemrm.com/
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e. The PreciseAssets GeoEvent definition associated with your geodatabase feature class 

should now exist.  The name may differ based on the location and type of DBMS used. 
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Creating the GeoEvent Service 

The GeoEvent Service creates the association between the PreCise-AVL-Connector (as an input) and the 

PreCiseAssets feature class / service (as an output).  The GeoEvent Service allows for custom field 

mapping and record processing between the input and output.  This example will show the full field 

mapping available from the PreCiseAssetRecord GeoEvent definition. 

1. Open ArcGIS GeoEvent Manager 

a.  https://<ArcGIS Server IP>:6143/geoevent/manager 

2. You should already have the PreCise-AVL-Connector created 

a. Refer to PreCise ArcGIS GeoEvent Connector 10.3.pdf 

3. Creating an Output 

a. Go to Services -> Outputs 

b. Click the Add Output button 

 
c. In the Output Connectors window, click the Select button for Add a Feature 

 
i. Add a Feature is used in this example to add all incoming records to the feature class. 

d. Create the output with the following settings: 

i. Name:  PreCiseAssets-FeatureClass 

ii. ArcGIS Server Connection:  Select the registered ArcGIS connection created earlier 

iii. Folder:  Select the folder containing the shared PreCiseAssets service on your ArcGIS 

Server 

iv. Service Name:  Select the PreCiseAssets feature service created earlier 

v. Layer:  Select the PreciseAssets feature layer shared via the PreCiseAssets service 

vi. Update Interval:  1 second 

http://www.precisemrm.com/
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vii. Click the Save button 

4. Creating a GeoEvent Service 

a. Go to Services -> GeoEvent Services 

b. Click the Add Service button 

 
c. Create the service with the following: 

i. Service Name:  PreCiseConnector-PreCiseAssetsFeature 
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ii. Service Description:  Connects PreCise MRM AVL data to the PreCiseAssets feature 

class. 

 
iii. Click Create 

d. The GeoEvent Service design screen will appear allowing input, output and filters/processors 

to be drag and dropped in the service design. 

e. Drag and drop the PreCise-AVL-Connector into the design from Inputs 

f. Drag and drop the PreCiseAssets-FeatureClass into the design from Outputs 

g. Drag and drop the Processor into the design from New Elements 

h. Create the Processor with the following properties: 

i. Name:  PreCiseAssetRecord-PreCiseAssets-FieldMapping 

ii. Processor:  Field Mapper 

iii. Source GeoEvent Definition:  PreCiseAssetRecord  

iv. Target GeoEvent Definition:  PreciseAssets GeoEvent definition associated with your 

geodatabase feature class.  arcgis_DBO_PreciseAssets in this example. 

v. A mapping of Source Fields to Target Fields will display.  Core Source Field types will 

automatically map to like-named fields in the Target Fields.  Special/Hierarchical field 

http://www.precisemrm.com/
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types such as Input data and Force America Spreader data require manual mapping. 

 
vi. When mapping Input data, the data is accessed via a zero-based array.  To access the 

data for the AVL physical Input #1, use Input[0].<fieldname>.  To access the data for 
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the AVL physical Input #2, use Input[1].<fieldname>, and so on. 
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vii. When mapping Force America Spreader data, the data is accessed via the 

FASpreaderStatus.<fieldname> structure. 

 
viii. Lastly, the geometry field must be defined in the field mapping. 

Source Field:  Location 

Target Field:  geometry 

 
ix. Click OK 
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i. With the Input, Processor and Output components added to the design, connect each 

component as shown in the screen shot 

 
j. Click Publish 

5. Starting the GeoEvent Service 

a. Go to Services -> Monitor 

b. Click the Start  button next to each service.  The services should be started in the 

following order: 

i. GeoEvent Service:  PreCiseConnector-PreCiseAssetsFeature 

ii. Output:  PreCiseAsset-FeatureClass 

iii. Input:  PreCise-AVL-Connector 

http://www.precisemrm.com/
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c. The Monitor screen will show the status and number of records processed by each 

component

 

 

  

http://www.precisemrm.com/


 
 

Page | 28 
 

PreCise MRM, LLC  -  A Subsidiary of FORCE America, Inc.  
1311 East Franklin Road, Suite 101/102  Meridian, ID 83642 

www.precisemrm.com  1-888-449-0357 

Verifying the Data 

The GeoEvent Service is now enabled for downloading PreCise MRM AVL data into a geodatabase 

feature class.  At this point the data can be verified using several methods.  For this example, ArcMap 

will be used to display the AVL data over an appropriate basemap layer. 

1. Open ArcMap 

2. In the ArcMap – Getting Started window, choose the PreciseAssets.mxd file saved earlier in this 

document. 

3. Select File -> Add Data -> Add Basemap 

a. Select an appropriate basemap, such as Streets 

b. Click Add 

4. Right-click the PreciseAssets layer, select  Properties 

5. On the Symbology tab  

a. Select Categories -> Unique Values  

b. Set the Value Field = AssetName (groups asset entries based on the Asset Name when 

viewed) 
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c. Click Add All Values 

 
d. Click OK 
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6. With the PreCise MRM AVL data displayed over the basemap you can check point information and 

visually verify that point data appears in the proper location. 
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GeoEvent Definition Structure 

The PreCise MRM GeoEvent Connector creates GeoEvent records based on the PreCiseAssetRecord 

GeoEvent definition that is included with the Connector installation.  The GeoEvent definition uses a 

hierarchical structure that can be mapped to flat and/or reduced schemas via the GeoEvent Extensions 

built-in processor utilities. 

When mapping PreCiseAssetRecord fields to other GeoEvent services, at a minimum the following fields 

are required for location tracking.  Each of these fields are associated with tags used by ArcGIS Server. 

 AssetID 

 Location 

 RecordDateTime 

Each of the fields defined in the GeoEvent definition can be accessed directly via the field name, with 

the exception of the FASpreaderStatus field group and the Input field group. 

FASpreaderStatus fields can be accessed via FASpreaderStatus.<fieldname> when mapping the 

GeoEvent definition to an output service. 

http://www.precisemrm.com/


 
 

Page | 32 
 

PreCise MRM, LLC  -  A Subsidiary of FORCE America, Inc.  
1311 East Franklin Road, Suite 101/102  Meridian, ID 83642 

www.precisemrm.com  1-888-449-0357 

Example:  FASpreaderStatus.SpreaderStatus 

 

Input fields can be accessed as if accessing an array, by using an index number for the specific input 

being mapped via Input[index].<fieldname>.  The Input field is zero-based, so the AVL device physical 

Input #1 would be accessed via the index number 0 (zero), Input #2 via index number 1 (one) and so 

forth. 

Example:  Input[0].InputStatus 
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Known Issues 

- Feature inserts are batched, if a record insert fails (record already exists in DB) then all record 

inserts in that batch will fail. 

- If time is enabled on an output feature layer, it will effect record times on insert into the feature 

class.  Enable time on this layer should be disabled for any output feature class. 

 
- Some point data may appear at location 0, 0.  These are data points where the GPS sensor on 

the AVL device was unable to obtain a valid GPS satellite signal, resulting in no known location 

(and potentially date/time) for the data.   

o Such points can be filtered out via the addition of a GeoEvent Filter to the GeoEvent 

Service placed prior to the Feature output.   
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o Filtering Latitude != 0 AND Longitude != 0 
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